summaryrefslogtreecommitdiffstats
path: root/common/network/CMakeLists.txt
diff options
context:
space:
mode:
authorHenrik Andersson <henrik.andersson@cendio.com>2011-06-09 09:13:23 +0000
committerHenrik Andersson <henrik.andersson@cendio.com>2011-06-09 09:13:23 +0000
commit23029ccd59f9d2b15ea31f88905dd44fb9e81875 (patch)
tree888c0e6d0a0f8e984d130b8bb51f86a481ea62ba /common/network/CMakeLists.txt
parent17a48f051071773ede9a348ce8cd64c0790b9774 (diff)
downloadtigervnc-23029ccd59f9d2b15ea31f88905dd44fb9e81875.tar.gz
tigervnc-23029ccd59f9d2b15ea31f88905dd44fb9e81875.zip
Building the Xvnc server requires libtool control files of rdr, rfb,
network and Xregion, which a cmake build will NOT produce, this macro tries to create a libtool control file *.la for the specified target with libdependencies for a static library target. Due to the automake part of Xvnc references to libtool files in source tree you need to build vncviewer using cmake in the source tree. git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4482 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'common/network/CMakeLists.txt')
-rw-r--r--common/network/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/common/network/CMakeLists.txt b/common/network/CMakeLists.txt
index 2afba7c0..9f664de8 100644
--- a/common/network/CMakeLists.txt
+++ b/common/network/CMakeLists.txt
@@ -2,3 +2,5 @@ include_directories(${CMAKE_SOURCE_DIR}/common)
add_library(network STATIC
TcpSocket.cxx)
+
+libtool_create_control_file(network)