aboutsummaryrefslogtreecommitdiffstats
path: root/common/rfb/CMakeLists.txt
diff options
context:
space:
mode:
authorDRC <dcommander@users.sourceforge.net>2011-11-03 18:49:21 +0000
committerDRC <dcommander@users.sourceforge.net>2011-11-03 18:49:21 +0000
commit33c15e3a3a1db376feae90ef7521a107dd957752 (patch)
tree07a01bd47e977a94b2ead9d406fec736e0b613b4 /common/rfb/CMakeLists.txt
parent3004cb640aba2ed81d31444064aa8087990c7212 (diff)
downloadtigervnc-33c15e3a3a1db376feae90ef7521a107dd957752.tar.gz
tigervnc-33c15e3a3a1db376feae90ef7521a107dd957752.zip
If the client and server are using identical pixel formats, then perform Tight decoding directly into the viewer's back buffer, rather than going through the slow fillRect/imageRect routines.
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4757 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'common/rfb/CMakeLists.txt')
-rw-r--r--common/rfb/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/common/rfb/CMakeLists.txt b/common/rfb/CMakeLists.txt
index be03c646..27e3caa5 100644
--- a/common/rfb/CMakeLists.txt
+++ b/common/rfb/CMakeLists.txt
@@ -23,6 +23,7 @@ set(RFB_SOURCES
HextileDecoder.cxx
HextileEncoder.cxx
JpegCompressor.cxx
+ JpegDecompressor.cxx
KeyRemapper.cxx
LogWriter.cxx
Logger.cxx