summaryrefslogtreecommitdiffstats
path: root/common/rfb/Makefile.am
diff options
context:
space:
mode:
authorAdam Tkac <atkac@redhat.com>2008-10-22 14:47:09 +0000
committerAdam Tkac <atkac@redhat.com>2008-10-22 14:47:09 +0000
commita0d5fe3790af8c284be9ddc0ca369ecf21c67195 (patch)
tree958bee2a153c5c51bc97d1e40153b46c84cbf149 /common/rfb/Makefile.am
parent65b24feda1556dea7a4a7a92a162d5c6b0de13ce (diff)
downloadtigervnc-a0d5fe3790af8c284be9ddc0ca369ecf21c67195.tar.gz
tigervnc-a0d5fe3790af8c284be9ddc0ca369ecf21c67195.zip
[Bugfix] Handle conditional jpeg/zlib building through AM_CONDITIONAL to make
make dist working [Bugfix] #include <jpeglib.h> (not jpeg/jpeglib.h) in JpegCompressor.h git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@3043 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'common/rfb/Makefile.am')
-rw-r--r--common/rfb/Makefile.am17
1 files changed, 8 insertions, 9 deletions
diff --git a/common/rfb/Makefile.am b/common/rfb/Makefile.am
index f2106d18..29ffc950 100644
--- a/common/rfb/Makefile.am
+++ b/common/rfb/Makefile.am
@@ -46,20 +46,19 @@ librfb_la_SOURCES = $(HDRS) Blacklist.cxx CConnection.cxx CMsgHandler.cxx \
VNCServerST.cxx ZRLEEncoder.cxx ZRLEDecoder.cxx encodings.cxx \
secTypes.cxx util.cxx
+librfb_la_CPPFLAGS = -I$(top_srcdir)
+librfb_la_LIBADD =
+
if IRIX_COMPRESS
librfb_la_SOURCES += IrixCLJpegCompressor.cxx
+librfb_la_LIBADD += -lcl
endif
if IRIX_MEDIA
librfb_la_SOURCES += IrixDMJpegCompressor.cxx IrixDMIC_RawToJpeg.cxx
+librfb_la_LIBADD += -ldmedia
endif
-librfb_la_CPPFLAGS = -I$(top_srcdir) @JPEG_INCLUDE@
-
-librfb_la_LIBADD = @JPEG_LIB@
-
-if IRIX_COMPRESS
-librfb_la_LIBADD += -lcl
-endif
-if IRIX_MEDIA
-librfb_la_LIBADD += -ldmedia
+if INCLUDED_JPEG
+librfb_la_CPPFLAGS += -I$(top_srcdir)/jpeg
+librfb_la_LIBADD += $(top_srcdir)/jpeg/libjpeg.la
endif