summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDRC <dcommander@users.sourceforge.net>2011-02-08 23:43:17 +0000
committerDRC <dcommander@users.sourceforge.net>2011-02-08 23:43:17 +0000
commit1b6aba21f179991fee9dafe189ac4ec52d8fe298 (patch)
tree3d8cbf034eea4efef36e5ea65345891044ae2467 /configure.ac
parent0f090b3f2dd8600ea0484f065ec55b65997f353a (diff)
downloadtigervnc-1b6aba21f179991fee9dafe189ac4ec52d8fe298.tar.gz
tigervnc-1b6aba21f179991fee9dafe189ac4ec52d8fe298.zip
Check for the existence of setenv() in the system libraries and use the system version if it exists. This prevents "error: declaration of setenv() throws different exceptions" when building on certain Linux platforms.
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4263 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1ac63513..d13ecbdd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -173,6 +173,8 @@ fi
AC_LANG_RESTORE
AC_SUBST(INET_LIB)
+AC_CHECK_FUNC(setenv, AC_DEFINE([HAVE_SETENV], [1], [Is setenv() present?]))
+
dnl Check for zlib library
INCLUDED_ZLIB=no
AC_ARG_WITH([included-zlib],