summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDRC <dcommander@users.sourceforge.net>2010-11-04 18:20:15 +0000
committerDRC <dcommander@users.sourceforge.net>2010-11-04 18:20:15 +0000
commitecdc54753d6a5701710de7dc5bf02526efaf1e06 (patch)
treebd4ae143d1d6b827ba43c768ef2a22931c9aa836 /configure.ac
parent69df3768033a87e1ad5942a2b7e8073926c8026a (diff)
downloadtigervnc-ecdc54753d6a5701710de7dc5bf02526efaf1e06.tar.gz
tigervnc-ecdc54753d6a5701710de7dc5bf02526efaf1e06.zip
Static Xvnc build should now work with later versions of libgnutls that depend on libtasn1
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4184 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 811342ab..1909e336 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,7 +82,8 @@ AC_ARG_VAR(GNUTLS_LDFLAGS, [Custom linker flags for using GnuTLS, e.g. -L{GnuTLS
GNUTLS_LIBS=
if test "x$enable_gnutls" = xyes; then
if test "x$GNUTLS_LDFLAGS" = "x"; then
- GNUTLS_LDFLAGS='-lgnutls -lgcrypt -lgpg-error'
+ GNUTLS_LDFLAGS='-lgnutls -lgcrypt -lgpg-error -lz'
+ AC_CHECK_LIB([tasn1], [asn1_create_element], [GNUTLS_LDFLAGS="${GNUTLS_LDFLAGS} -ltasn1"])
fi
SAVE_LIBS=${LIBS}
LIBS="${LIBS} ${GNUTLS_LDFLAGS}"