summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2009-12-23 09:51:37 +0000
committerPierre Ossman <ossman@cendio.se>2009-12-23 09:51:37 +0000
commitf2180b2b6083d80919f33b58dc95cea6777795f7 (patch)
tree90976b862a2d7d36dd9f45402c41c77b5913447e /configure.ac
parent52a3a4f9ee69939c6c1218ff82a040764cfe66e8 (diff)
downloadtigervnc-f2180b2b6083d80919f33b58dc95cea6777795f7.tar.gz
tigervnc-f2180b2b6083d80919f33b58dc95cea6777795f7.zip
Make it possible to compile things with current upstream mingw. You'll lose
WinVNC but it is now possible to compile vncviewer at least. git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@3934 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3ba8a1cb..19a6d392 100644
--- a/configure.ac
+++ b/configure.ac
@@ -143,6 +143,13 @@ AC_CHECK_TYPES([socklen_t], [], [], [[#include <sys/socket.h>]])
AC_CHECK_HEADERS([sys/select.h])
+# Needed for WinVNC, but not part of mingw yet
+AC_CHECK_DECLS([CLSID_ActiveDesktop], [BUILD_WINVNC=yes], [],
+ [[#include <windows.h>
+ #include <shlguid.h>
+ ]])
+AM_CONDITIONAL([BUILD_WINVNC], [ test "x$BUILD_WINVNC" = xyes ])
+
AC_OUTPUT([
Makefile
common/Makefile