summaryrefslogtreecommitdiffstats
path: root/java/CMakeLists.txt
diff options
context:
space:
mode:
authorBrian P. Hinz <bphinz@users.sf.net>2017-11-13 19:00:01 -0500
committerBrian P. Hinz <bphinz@users.sf.net>2017-11-13 21:10:06 -0500
commit335446d164fc96a08c119171d696ffea030f71ff (patch)
tree5c2990246155d1ae00e35c3f755d5e690f7caa8d /java/CMakeLists.txt
parentbce950b70a310ff4614807aa2f0904a826b6b30a (diff)
downloadtigervnc-335446d164fc96a08c119171d696ffea030f71ff.tar.gz
tigervnc-335446d164fc96a08c119171d696ffea030f71ff.zip
Fix build Java errors caused by UTF-8 characters in source comments
See issue #534
Diffstat (limited to 'java/CMakeLists.txt')
-rw-r--r--java/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/java/CMakeLists.txt b/java/CMakeLists.txt
index 80e0dd26..7d6c70a8 100644
--- a/java/CMakeLists.txt
+++ b/java/CMakeLists.txt
@@ -9,7 +9,7 @@ find_package(Java)
set(DATA_DIR "${CMAKE_INSTALL_PREFIX}/share")
-set(DEFAULT_JAVACFLAGS "-source 7 -target 7 -Xlint:all,-serial,-cast,-unchecked,-fallthrough,-dep-ann,-deprecation,-rawtypes")
+set(DEFAULT_JAVACFLAGS "-source 7 -target 7 -encoding UTF-8 -Xlint:all,-serial,-cast,-unchecked,-fallthrough,-dep-ann,-deprecation,-rawtypes")
set(JAVACFLAGS ${DEFAULT_JAVACFLAGS} CACHE STRING
"Java compiler flags (Default: ${DEFAULT_JAVACFLAGS})")
message(STATUS "Java compiler flags = ${JAVACFLAGS}")