summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2014-07-04 14:12:49 +0200
committerPierre Ossman <ossman@cendio.se>2014-07-04 14:12:49 +0200
commit236c03cc333246be44a20569fcd0d1c2c82c4079 (patch)
tree9d37aa207190c71a4a59ffc3a28c84879222b20e /tests/CMakeLists.txt
parentf3c2026d5be5c64655386bb1d1592eb250830ea1 (diff)
downloadtigervnc-236c03cc333246be44a20569fcd0d1c2c82c4079.tar.gz
tigervnc-236c03cc333246be44a20569fcd0d1c2c82c4079.zip
Add pixel conversion speed test
Add a tests directory where we can put tests programs that can be useful during testing. Start with a speed test for the pixel conversion routines.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 00000000..fd47c15a
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,6 @@
+include_directories(${CMAKE_SOURCE_DIR}/common)
+
+add_library(test_util STATIC util.cxx)
+
+add_executable(pixelconv pixelconv.cxx)
+target_link_libraries(pixelconv test_util rfb)