summaryrefslogtreecommitdiffstats
path: root/unix/xserver/hw/vnc/Makefile.am
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2016-01-12 17:33:32 +0100
committerPierre Ossman <ossman@cendio.se>2016-01-12 18:39:09 +0100
commitc62e70c5b34de478127a130384b8958ccf232504 (patch)
treefb2c77b9c46cf37bbdb6207bd3ed3c77d4126a66 /unix/xserver/hw/vnc/Makefile.am
parentfc08bee5afdb07830d6c6fb28359a020a5c305c5 (diff)
downloadtigervnc-c62e70c5b34de478127a130384b8958ccf232504.tar.gz
tigervnc-c62e70c5b34de478127a130384b8958ccf232504.zip
Move client to server clipboard out of vncconfig
Handle the clipboard directly in the server, avoiding the dependency on vncconfig. This commit adds support for clipboard from the client to the server. Handling of the other direction will follow.
Diffstat (limited to 'unix/xserver/hw/vnc/Makefile.am')
-rw-r--r--unix/xserver/hw/vnc/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/unix/xserver/hw/vnc/Makefile.am b/unix/xserver/hw/vnc/Makefile.am
index d7ab2595..95b03d2d 100644
--- a/unix/xserver/hw/vnc/Makefile.am
+++ b/unix/xserver/hw/vnc/Makefile.am
@@ -10,11 +10,12 @@ COMMON_LIBS=$(NETWORK_LIB) $(RFB_LIB) $(RDR_LIB) $(XREGION_LIB)
noinst_LTLIBRARIES = libvnccommon.la
HDRS = vncExtInit.h vncHooks.h \
- vncBlockHandler.h XorgGlue.h \
- XserverDesktop.h xorg-version.h \
+ vncBlockHandler.h vncSelection.h \
+ XorgGlue.h XserverDesktop.h xorg-version.h \
Input.h RFBGlue.h
-libvnccommon_la_SOURCES = $(HDRS) vncExt.c vncExtInit.cc vncHooks.c \
+libvnccommon_la_SOURCES = $(HDRS) \
+ vncExt.c vncExtInit.cc vncHooks.c vncSelection.c \
vncBlockHandler.c XorgGlue.c RFBGlue.cc XserverDesktop.cc \
Input.c InputXKB.c