summaryrefslogtreecommitdiffstats
path: root/vncviewer/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2014-02-07 14:46:26 +0100
committerPierre Ossman <ossman@cendio.se>2014-07-07 14:50:28 +0200
commitac13abe4ce9f74522acd9697a08dc56de8e2949f (patch)
tree4eb0fdaa6cf22d0e06f63b9cb1a03063f5f21c27 /vncviewer/CMakeLists.txt
parent668468b3d43d5ea1562ebc0be8de0c98c5601a60 (diff)
downloadtigervnc-ac13abe4ce9f74522acd9697a08dc56de8e2949f.tar.gz
tigervnc-ac13abe4ce9f74522acd9697a08dc56de8e2949f.zip
Create a proper interface base class for the viewport's framebuffer
This allows us to gracefully fall back to the FLTK code in case the platform specific code cannot be used.
Diffstat (limited to 'vncviewer/CMakeLists.txt')
-rw-r--r--vncviewer/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/vncviewer/CMakeLists.txt b/vncviewer/CMakeLists.txt
index c1facc67..9b815a39 100644
--- a/vncviewer/CMakeLists.txt
+++ b/vncviewer/CMakeLists.txt
@@ -7,9 +7,11 @@ set(VNCVIEWER_SOURCES
menukey.cxx
CConn.cxx
DesktopWindow.cxx
+ FLTKPixelBuffer.cxx
UserDialog.cxx
ServerDialog.cxx
OptionsDialog.cxx
+ PlatformPixelBuffer.cxx
Viewport.cxx
parameters.cxx
keysym2ucs.c