summaryrefslogtreecommitdiffstats
path: root/vncviewer/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2017-07-19 10:56:21 +0200
committerPierre Ossman <ossman@cendio.se>2017-07-19 10:59:09 +0200
commit86ff9fdbfa37e0ee2dccee9b2e9b92645f3bcb8e (patch)
tree3a3a835ea503699ef7547c00b61b7dce07720035 /vncviewer/CMakeLists.txt
parent8aff08ced1ae646e28098027343498b850d0ec13 (diff)
downloadtigervnc-86ff9fdbfa37e0ee2dccee9b2e9b92645f3bcb8e.tar.gz
tigervnc-86ff9fdbfa37e0ee2dccee9b2e9b92645f3bcb8e.zip
Generate translations in .desktop file from po files
Diffstat (limited to 'vncviewer/CMakeLists.txt')
-rw-r--r--vncviewer/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/vncviewer/CMakeLists.txt b/vncviewer/CMakeLists.txt
index 1833e704..282ed9da 100644
--- a/vncviewer/CMakeLists.txt
+++ b/vncviewer/CMakeLists.txt
@@ -59,7 +59,14 @@ endif()
install(TARGETS vncviewer DESTINATION ${BIN_DIR})
if(UNIX)
install(FILES vncviewer.man DESTINATION ${MAN_DIR}/man1 RENAME vncviewer.1)
- configure_file(vncviewer.desktop.in vncviewer.desktop)
+ configure_file(vncviewer.desktop.in.in vncviewer.desktop.in)
+ add_custom_command(OUTPUT vncviewer.desktop
+ COMMAND ${GETTEXT_MSGFMT_EXECUTABLE}
+ --desktop --template vncviewer.desktop.in
+ -d ${CMAKE_SOURCE_DIR}/po -o vncviewer.desktop
+ DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/vncviewer.desktop.in
+ )
+ add_custom_target(desktop ALL DEPENDS vncviewer.desktop)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/vncviewer.desktop DESTINATION ${DATA_DIR}/applications)
foreach(res 16 22 24 32 48)
install(FILES ../media/icons/tigervnc_${res}.png DESTINATION ${DATA_DIR}/icons/hicolor/${res}x${res}/apps RENAME tigervnc.png)