summaryrefslogtreecommitdiffstats
path: root/win/rfb_win32/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2016-01-12 12:32:15 +0100
committerPierre Ossman <ossman@cendio.se>2016-01-12 12:32:15 +0100
commitfc08bee5afdb07830d6c6fb28359a020a5c305c5 (patch)
treee2009681235886e7c9e6669f0939b679815fcfab /win/rfb_win32/CMakeLists.txt
parent4ab1e5d4b5ebaac0c410eedcc76865736aaa6ae4 (diff)
downloadtigervnc-fc08bee5afdb07830d6c6fb28359a020a5c305c5.tar.gz
tigervnc-fc08bee5afdb07830d6c6fb28359a020a5c305c5.zip
Remove legacy Windows code
We have lots of code that deals with Windows versions that we no longer support anyway. Clean out all of this old cruft.
Diffstat (limited to 'win/rfb_win32/CMakeLists.txt')
-rw-r--r--win/rfb_win32/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/win/rfb_win32/CMakeLists.txt b/win/rfb_win32/CMakeLists.txt
index 99d52779..047b0d86 100644
--- a/win/rfb_win32/CMakeLists.txt
+++ b/win/rfb_win32/CMakeLists.txt
@@ -6,13 +6,11 @@ set(RFB_WIN32_SOURCES
DeviceFrameBuffer.cxx
Dialog.cxx
DIBSectionBuffer.cxx
- DynamicFn.cxx
EventManager.cxx
LaunchProcess.cxx
ListViewControl.cxx
MonitorInfo.cxx
MsgWindow.cxx
- OSVersion.cxx
RegConfig.cxx
Registry.cxx
SecurityPage.cxx
@@ -40,4 +38,4 @@ endif()
add_library(rfb_win32 STATIC ${RFB_WIN32_SOURCES})
-target_link_libraries(rfb_win32 user32.lib comctl32.lib version.lib)
+target_link_libraries(rfb_win32 user32.lib comctl32.lib wtsapi32.lib version.lib)