summaryrefslogtreecommitdiffstats
path: root/win/rfb_win32/Makefile.am
diff options
context:
space:
mode:
authorPeter Åstrand <astrand@cendio.se>2008-12-09 10:27:33 +0000
committerPeter Åstrand <astrand@cendio.se>2008-12-09 10:27:33 +0000
commiteaff3bc8fa335b322981173fb3a8bfa158d88227 (patch)
tree044a77f27839ef61ef9ec92853ddae31f7014c86 /win/rfb_win32/Makefile.am
parent00e0dbfdcbad585795300ee9c7d8cabab5eb487c (diff)
downloadtigervnc-eaff3bc8fa335b322981173fb3a8bfa158d88227.tar.gz
tigervnc-eaff3bc8fa335b322981173fb3a8bfa158d88227.zip
Basic support for building Windows vncviewer using MinGW. This patch
includes non-intrusive changes, more tweaks will follow. Details: * Defining WINVER and _WIN32_IE in both common and win modules. * Need to build CFTMsgWriter and CFTMsgReader. * Added configure script and Makefiles. git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@3326 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'win/rfb_win32/Makefile.am')
-rw-r--r--win/rfb_win32/Makefile.am109
1 files changed, 109 insertions, 0 deletions
diff --git a/win/rfb_win32/Makefile.am b/win/rfb_win32/Makefile.am
new file mode 100644
index 00000000..9ba8e4b7
--- /dev/null
+++ b/win/rfb_win32/Makefile.am
@@ -0,0 +1,109 @@
+noinst_LTLIBRARIES = librfb_win32.la
+
+HDRS = \
+ AboutDialog.h \
+ BitmapInfo.h \
+ CKeyboard.h \
+ CleanDesktop.h \
+ Clipboard.h \
+ CompatibleBitmap.h \
+ ComputerName.h \
+ CPointer.h \
+ CurrentUser.h \
+ DeviceContext.h \
+ DeviceFrameBuffer.h \
+ Dialog.h \
+ DIBSectionBuffer.h \
+ DynamicFn.h \
+ EventManager.h \
+ FolderManager.h \
+ Handle.h \
+ IconInfo.h \
+ IntervalTimer.h \
+ keymap.h \
+ LaunchProcess.h \
+ ListViewControl.h \
+ LocalMem.h \
+ LogicalPalette.h \
+ LowLevelKeyEvents.h \
+ ModuleFileName.h \
+ MonitorInfo.h \
+ MsgBox.h \
+ MsgWindow.h \
+ OSVersion.h \
+ ProgressControl.h \
+ RegConfig.h \
+ Registry.h \
+ ScaledDIBSectionBuffer.h \
+ SDisplayCoreDriver.h \
+ SDisplayCorePolling.h \
+ SDisplayCoreWMHooks.h \
+ SDisplay.h \
+ Security.h \
+ Service.h \
+ SFileTransferManagerWin32.h \
+ SFileTransferWin32.h \
+ SInput.h \
+ SocketManager.h \
+ TCharArray.h \
+ Threading.h \
+ ToolBar.h \
+ TrayIcon.h \
+ TsSessions.h \
+ Win32Util.h \
+ WMCursor.h \
+ WMHooks.h \
+ WMNotifier.h \
+ WMPoller.h \
+ WMShatter.h \
+ WMWindowCopyRect.h
+
+
+## CleanDesktop.cxx not built - MinGW does not provide COM
+
+librfb_win32_la_SOURCES = $(HDRS) \
+ AboutDialog.cxx \
+ CKeyboard.cxx \
+ Clipboard.cxx \
+ CPointer.cxx \
+ CurrentUser.cxx \
+ DeviceContext.cxx \
+ DeviceFrameBuffer.cxx \
+ Dialog.cxx \
+ DIBSectionBuffer.cxx \
+ DynamicFn.cxx \
+ EventManager.cxx \
+ FolderManager.cxx \
+ LaunchProcess.cxx \
+ ListViewControl.cxx \
+ LowLevelKeyEvents.cxx \
+ MonitorInfo.cxx \
+ MsgWindow.cxx \
+ OSVersion.cxx \
+ ProgressControl.cxx \
+ RegConfig.cxx \
+ Registry.cxx \
+ ScaledDIBSectionBuffer.cxx \
+ SDisplayCorePolling.cxx \
+ SDisplayCoreWMHooks.cxx \
+ SDisplay.cxx \
+ Security.cxx \
+ Service.cxx \
+ SFileTransferManagerWin32.cxx \
+ SFileTransferWin32.cxx \
+ SInput.cxx \
+ SocketManager.cxx \
+ TCharArray.cxx \
+ Threading.cxx \
+ ToolBar.cxx \
+ TsSessions.cxx \
+ Win32Util.cxx \
+ WMCursor.cxx \
+ WMHooks.cxx \
+ WMNotifier.cxx \
+ WMPoller.cxx \
+ WMShatter.cxx \
+ WMWindowCopyRect.cxx
+
+librfb_win32_la_CPPFLAGS = -I$(top_srcdir) -I$(COMMON_DIR)
+librfb_win32_la_LIBADD =