aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0fdd3c66..ace5ffa3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -241,6 +241,10 @@ if(ENABLE_GNUTLS)
set(CMAKE_REQUIRED_FLAGS -I${GNUTLS_INCLUDE_DIR})
set(CMAKE_EXTRA_INCLUDE_FILES gnutls/gnutls.h)
set(CMAKE_REQUIRED_LIBRARIES ${GNUTLS_LIBRARIES})
+ if(WIN32)
+ set(CMAKE_EXTRA_INCLUDE_FILES gcrypt.h ${CMAKE_EXTRA_INCLUDE_FILES})
+ set(CMAKE_REQUIRED_LIBRARIES ${CMAKE_REQUIRED_LIBRARIES} ws2_32 user32)
+ endif()
if(ZLIB_FOUND)
# When we build against the static version of GnuTLS, we also use the
# included version of Zlib, but it isn't built yet, so we have to use the