summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 252a42c8..9cf3dd32 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -356,7 +356,8 @@ if(ENABLE_GNUTLS)
# system's version (if available) to perform this test.
set(CMAKE_REQUIRED_LIBRARIES ${CMAKE_REQUIRED_LIBRARIES};-lz)
endif()
- check_function_exists(gnutls_transport_set_global_errno HAVE_OLD_GNUTLS)
+ check_function_exists(gnutls_transport_set_errno HAVE_GNUTLS_SET_ERRNO)
+ check_function_exists(gnutls_transport_set_global_errno HAVE_GNUTLS_SET_GLOBAL_ERRNO)
check_function_exists(gnutls_x509_crt_print HAVE_GNUTLS_X509_CRT_PRINT)
check_type_size(gnutls_x509_crt_t GNUTLS_X509_CRT_T)
check_type_size(gnutls_datum_t GNUTLS_DATUM_T)