summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 16 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 88af909c..6f84b30f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -247,23 +247,15 @@ if(UNIX AND NOT APPLE)
# No proper handling for extra X11 libs that FLTK might need...
if(X11_Xft_FOUND)
set(FLTK_LIBRARIES ${FLTK_LIBRARIES} ${X11_Xft_LIB})
- else()
- message(FATAL_ERROR "Xft headers/libraries not found (needed by FLTK.)")
endif()
if(X11_Xinerama_FOUND)
set(FLTK_LIBRARIES ${FLTK_LIBRARIES} ${X11_Xinerama_LIB})
- else()
- message(FATAL_ERROR "Xinerama headers/libraries not found (needed by FLTK.)")
endif()
if(X11_Xfixes_FOUND)
set(FLTK_LIBRARIES ${FLTK_LIBRARIES} ${X11_Xfixes_LIB})
- else()
- message(FATAL_ERROR "Xfixes headers/libraries not found (needed by FLTK.)")
endif()
if(X11_Xcursor_FOUND)
set(FLTK_LIBRARIES ${FLTK_LIBRARIES} ${X11_Xcursor_LIB})
- else()
- message(FATAL_ERROR "Xcursor headers/libraries not found (needed by FLTK.)")
endif()
endif()
@@ -298,6 +290,22 @@ if(NOT FLTK_FOUND OR NOT HAVE_FLTK_DEAD_KEYS OR NOT HAVE_FLTK_CLIPBOARD
set(USE_INCLUDED_FLTK 1)
endif()
if(USE_INCLUDED_FLTK)
+ # Check that we have the proper dependencies
+ if(UNIX AND NOT APPLE)
+ if(NOT X11_Xft_FOUND)
+ message(FATAL_ERROR "Xft headers/libraries not found (needed by FLTK.)")
+ endif()
+ if(NOT X11_Xinerama_FOUND)
+ message(FATAL_ERROR "Xinerama headers/libraries not found (needed by FLTK.)")
+ endif()
+ if(NOT X11_Xfixes_FOUND)
+ message(FATAL_ERROR "Xfixes headers/libraries not found (needed by FLTK.)")
+ endif()
+ if(NOT X11_Xcursor_FOUND)
+ message(FATAL_ERROR "Xcursor headers/libraries not found (needed by FLTK.)")
+ endif()
+ endif()
+
set(HAVE_FLTK_DEAD_KEYS 1)
set(HAVE_FLTK_CLIPBOARD 1)
set(HAVE_FLTK_MEDIAKEYS 1)