summaryrefslogtreecommitdiffstats
path: root/common/jpeg/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/jpeg/Makefile.am')
-rw-r--r--common/jpeg/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/common/jpeg/Makefile.am b/common/jpeg/Makefile.am
index 57081f7e..0e7ae4d6 100644
--- a/common/jpeg/Makefile.am
+++ b/common/jpeg/Makefile.am
@@ -10,14 +10,17 @@ libjpeg_la_SOURCES = $(HDRS) jcapimin.c jcapistd.c jccoefct.c jccolor.c \
jddctmgr.c jdhuff.c jdinput.c jdmainct.c jdmarker.c jdmaster.c \
jdmerge.c jdphuff.c jdpostct.c jdsample.c jdtrans.c jerror.c \
jfdctflt.c jfdctfst.c jfdctint.c jidctflt.c jidctfst.c jidctint.c \
- jidctred.c jquant1.c jquant2.c jutils.c jmemmgr.c jmemnobs.c \
- jsimd.c
+ jidctred.c jquant1.c jquant2.c jutils.c jmemmgr.c jmemnobs.c
if WITH_SIMD
SUBDIRS = simd
libjpeg_la_LIBADD = simd/libsimd.la
+else
+
+libjpeg_la_SOURCES += jsimd_none.c
+
endif
TSTHDRS = turbojpeg.h rrutil.h rrtimer.h