aboutsummaryrefslogtreecommitdiffstats
path: root/common/network/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'common/network/CMakeLists.txt')
-rw-r--r--common/network/CMakeLists.txt8
1 files changed, 0 insertions, 8 deletions
diff --git a/common/network/CMakeLists.txt b/common/network/CMakeLists.txt
index 681d2912..ddde5745 100644
--- a/common/network/CMakeLists.txt
+++ b/common/network/CMakeLists.txt
@@ -3,14 +3,6 @@ include_directories(${CMAKE_SOURCE_DIR}/common)
add_library(network STATIC
TcpSocket.cxx)
-# This code goes into libvnc.so, so it needs to be PIC on x86_64.
-# (It should be on archs as well, but we prefer performance over memory
-# efficiency. Win64 is excluded because PIC is always on there and it
-# complains when you give it the explicit flag.)
-if(CMAKE_COMPILER_IS_GNUCXX AND (CMAKE_SIZEOF_VOID_P MATCHES 8) AND NOT WIN32)
- set_target_properties(network PROPERTIES COMPILE_FLAGS -fPIC)
-endif()
-
if(UNIX)
libtool_create_control_file(network)
endif()