aboutsummaryrefslogtreecommitdiffstats
path: root/unix/vncconfig/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'unix/vncconfig/CMakeLists.txt')
-rw-r--r--unix/vncconfig/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/unix/vncconfig/CMakeLists.txt b/unix/vncconfig/CMakeLists.txt
index 8734ff63..0589f161 100644
--- a/unix/vncconfig/CMakeLists.txt
+++ b/unix/vncconfig/CMakeLists.txt
@@ -1,14 +1,14 @@
-include_directories(SYSTEM ${X11_INCLUDE_DIR})
-
-include_directories(${CMAKE_SOURCE_DIR}/common)
-include_directories(${CMAKE_SOURCE_DIR}/unix/tx)
-
add_executable(vncconfig
buildtime.c
vncExt.c
vncconfig.cxx
QueryConnectDialog.cxx)
+target_include_directories(vncconfig SYSTEM PUBLIC ${X11_INCLUDE_DIR})
+
+target_include_directories(vncconfig PUBLIC ${CMAKE_SOURCE_DIR}/common)
+target_include_directories(vncconfig PUBLIC ${CMAKE_SOURCE_DIR}/unix/tx)
+
target_link_libraries(vncconfig tx rfb network rdr ${X11_LIBRARIES})
install(TARGETS vncconfig DESTINATION ${CMAKE_INSTALL_FULL_BINDIR})