summaryrefslogtreecommitdiffstats
path: root/vncviewer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'vncviewer/CMakeLists.txt')
-rw-r--r--vncviewer/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/vncviewer/CMakeLists.txt b/vncviewer/CMakeLists.txt
index faa1f755..12cd8aee 100644
--- a/vncviewer/CMakeLists.txt
+++ b/vncviewer/CMakeLists.txt
@@ -21,7 +21,9 @@ if(APPLE)
set(VNCVIEWER_SOURCES ${VNCVIEWER_SOURCES} cocoa.mm)
endif()
-if((NOT APPLE) AND (NOT WIN32))
+if(WIN32)
+ set(VNCVIEWER_SOURCES ${VNCVIEWER_SOURCES} Win32PixelBuffer.cxx)
+elseif(NOT APPLE)
set(VNCVIEWER_SOURCES ${VNCVIEWER_SOURCES} X11PixelBuffer.cxx)
endif()