summaryrefslogtreecommitdiffstats
path: root/win/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'win/CMakeLists.txt')
-rw-r--r--win/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/win/CMakeLists.txt b/win/CMakeLists.txt
new file mode 100644
index 00000000..ee0a5c02
--- /dev/null
+++ b/win/CMakeLists.txt
@@ -0,0 +1,12 @@
+add_definitions(-D_WIN32_IE=0x0500 -D_WIN32_WINNT=0x0500)
+
+include_directories(${CMAKE_SOURCE_DIR}/common ${CMAKE_SOURCE_DIR}/win)
+
+configure_file(resdefs.h.in resdefs.h)
+
+add_subdirectory(rfb_win32)
+add_subdirectory(vncviewer)
+if(BUILD_WINVNC)
+add_subdirectory(vncconfig)
+add_subdirectory(winvnc)
+endif()