summaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
...
| * | Test results comparing PixelTransformer and bufferFromBuffer()Pierre Ossman2014-07-094-0/+106
| | |
| * | Add optimised buffer conversionPierre Ossman2014-07-093-0/+291
| | | | | | | | | | | | | | | | | | | | | | | | | | | Handles the common cases when the target or source are in the preferred 888 format. If one of the buffers is not 888, then it must also be properly aligned (which is commonly the case). Performance is now in many cases on par with PixelTransformer.
| * | Add ability to directly convert between two pixel formatsPierre Ossman2014-07-093-0/+65
| | | | | | | | | | | | | | | This is a lot easier and cheaper than having to set up a complete PixelTransformer object.
| * | Use lookup tables for pixel upconversionPierre Ossman2014-07-093-44/+64
| | | | | | | | | | | | | | | | | | You have to loop many times when converting e.g. 2 bits to 8, so have a couple of lookup tables to speed things up. We still use bit replication to get from 8 bits to 16 bits though.
| * | Put some space between the groups of testsPierre Ossman2014-07-091-0/+8
| | |
| * | Add more 8 bpp conversion testsPierre Ossman2014-07-091-0/+13
| | |
| * | Only grab the regions we actually needPierre Ossman2014-07-071-22/+33
| | | | | | | | | | | | | | | Allows pixel buffers that do damage tracking to get proper information.
| * | Provide a better R/W base PixelBuffer classPierre Ossman2014-07-079-32/+103
| | | | | | | | | | | | | | | Clearly separates the read API from the write API and also from actual implementation.
* | | Merge branch 'nocolourmap' of https://github.com/CendioOssman/tigervncPierre Ossman2014-07-14110-3514/+1990
|\| |
| * | Get rid of getStride()Pierre Ossman2014-07-0714-53/+25
| | | | | | | | | | | | | | | | | | It was confusing and not properly used everywhere. Callers should use the stride they get when they get the buffer pointer.
| * | Get rid of the direct access abuse of FullFramePixelBuffer's dataPierre Ossman2014-07-078-27/+58
| | |
| * | We don't need a fillRect() that is this optimisedPierre Ossman2014-07-072-83/+19
| | | | | | | | | | | | | | | Keep things simple instead and allows us to remove the extra setPF() methods.
| * | Avoid having virtual methods where not neededPierre Ossman2014-07-072-17/+10
| | |
| * | getImage() doesn't need to be overloadable, keep it simplePierre Ossman2014-07-073-38/+5
| | |
| * | Create a proper interface base class for the viewport's framebufferPierre Ossman2014-07-0713-73/+195
| | | | | | | | | | | | | | | This allows us to gracefully fall back to the FLTK code in case the platform specific code cannot be used.
| * | Encoders/decoders should track the connection objectPierre Ossman2014-07-0735-110/+103
| | | | | | | | | | | | | | | | | | The connection object is a much more appropriate object for the decoders and encoders to keep track of. Besides the streams, it also contains state like connection parameters.
| * | Push encoder and decoder handling down into the connection objectsPierre Ossman2014-07-0711-152/+87
| | | | | | | | | | | | | | | This keeps the reader and writer objects clean and simple protocol decoders/encoders.
| * | Remove full support for colour mapsPierre Ossman2014-07-0748-1247/+309
| | | | | | | | | | | | | | | | | | | | | | | | | | | Gets rid of a loooot of code and complexity. Colour map clients are still supported through an automatically generated map, but we lose the ability to develop a client or server that uses colour maps internally.
| * | Get rid of unnecessary macros as they are only ever set to a single thingPierre Ossman2014-07-0715-85/+30
| | |
| * | Push encoding specific formats into the encoders and decodersPierre Ossman2014-07-0712-63/+91
| | | | | | | | | | | | Keep the generic stream classes clean and general.
| * | Consolidate the different palette handler implementationsPierre Ossman2014-07-078-493/+272
| | |
| * | Handle CopyRect like any other encodingPierre Ossman2014-07-077-21/+86
| | | | | | | | | | | | Avoids having to special case things. Keeps the code simpler.
| * | Avoid reader/writer duplication in every encoder/decoderPierre Ossman2014-07-0724-26/+27
| | |
| * | Remove partial update functionalityPierre Ossman2014-07-0715-80/+46
| | | | | | | | | | | | | | | | | | Get rid of the ability of encoders to only send part of the rectangle they are given as we don't want partial updates anyway.
| * | Move serialisation of pseudorects into separate functionsPierre Ossman2014-07-072-69/+72
| | | | | | | | | | | | Keeps the code clearer.
| * | Merge the "V3" message classes into the normal onesPierre Ossman2014-07-0720-1140/+818
| |/ | | | | | | We have no need for this abstraction so let's keep things simple.
* | Merge branch 'inputreset' of https://github.com/CendioOssman/tigervncPierre Ossman2014-07-147-77/+69
|\ \ | |/ |/|
| * Handle closing of input devicesPierre Ossman2014-07-142-6/+5
| | | | | | | | | | | | The core can decide to close an input device (e.g. during a server reset). Make sure we respect this by forgetting about the device and recreating it again later.
| * Remove private storage from InputDevicePierre Ossman2014-07-141-27/+2
| | | | | | | | | | We don't need this anymore as we now only have a single InputDevice object and can easily refer to it directly.
| * Make InputDevice into a singletonPierre Ossman2014-07-144-23/+34
| | | | | | | | | | Xorg input devices are global so it doesn't make sense that we have one InputDevice object per XserverDesktop.
| * Move all functions that InputDevice uses into the classPierre Ossman2014-07-143-5/+8
| |
| * Let XserverDesktop handle syncing cursor positionPierre Ossman2014-07-144-18/+20
| | | | | | | | | | This makes InputDevice cleaner and just a glue layer for Xorg input devices.
| * Re-init VNC extension on server resetPierre Ossman2014-07-141-2/+2
| | | | | | | | | | | | | | | | fc23895 blocked out a bit too much code when trying to make libvnc handle server resets. Even though configuration should only be handled once, the underlying VNC extension needs to be reinitilised as the X core has removed all extensions on reset.
| * We need to set a label on all pointer buttonsPierre Ossman2014-07-111-0/+2
|/
* Merge branch 'pixeltest' of https://github.com/CendioOssman/tigervncPierre Ossman2014-07-077-2/+314
|\
| * Add pixel conversion speed testPierre Ossman2014-07-045-0/+312
| | | | | | | | | | | | Add a tests directory where we can put tests programs that can be useful during testing. Start with a speed test for the pixel conversion routines.
| * librfb needs librdr so make sure it always gets pulled inPierre Ossman2014-07-042-2/+2
| |
* | Merge branch 'cleanup' of https://github.com/CendioOssman/tigervncPierre Ossman2014-07-07112-4856/+763
|\ \ | |/ |/|
| * Remove a lot of platform compatibilty stuffPierre Ossman2014-07-0727-450/+10
| | | | | | | | It's either not used, or no longer relevant.
| * Remove remnants of Windows only clientPierre Ossman2014-07-0712-1346/+0
| |
| * Fix some offenders that poke around in the PixelFormat internalsPierre Ossman2014-07-076-113/+116
| |
| * Avoid code duplication for the linear pixel format conversion methodsPierre Ossman2014-07-071-79/+2
| |
| * Consistent use of stride vs pitchPierre Ossman2014-07-076-23/+24
| | | | | | | | | | | | | | Consistently use the term stride rather than pitch. Also consistently represent the stride in number of pixels rather than number of bytes. There is so much code that assumes proper alignment already that we do not need the extra resolution.
| * Fix possible information leakagePierre Ossman2014-07-071-2/+11
| | | | | | | | Zero the padding byte used when converting 24-bit RGB to 32-bit.
| * Use the same algorithm for conversionsPierre Ossman2014-07-071-73/+53
| | | | | | | | | | | | Make sure that the routines that convert between buffer and rgb representations follow the same algorithm so it's easier to compare them.
| * Optimise the RGB to pixel conversion to simple shiftsPierre Ossman2014-07-073-51/+65
| | | | | | | | | | Might as well make it inline at this point as well as it is used heavily in other routines that convert entire blocks of pixels.
| * Remove magic JPEG variables from ConnParamsPierre Ossman2014-07-074-23/+19
| | | | | | | | | | | | Custom compression level and JPEG on/off are not inherent parts of the protocol negotiation so they do not belong in ConnParams. Let the UI frontend handle such things instead.
| * Clean up the encoding parser in ConnParamsPierre Ossman2014-07-071-48/+55
| |
| * Make the subsampling setting follow the common stylePierre Ossman2014-07-078-45/+64
| |
| * Remove some premature optimisationPierre Ossman2014-07-076-74/+104
| | | | | | | | Reduces header dependencies.