aboutsummaryrefslogtreecommitdiffstats
path: root/common/rfb
Commit message (Collapse)AuthorAgeFilesLines
...
| * VncAuth: Read and use readonly password.Michal Srb2014-11-102-25/+47
| | | | | | | | | | Try to read second password (for read only access) from rfbauth file. If client sent second password instead of first one, allow him read only access.
| * Allow SSecurity to specify AccessRights for SConnection.Michal Srb2014-11-105-5/+7
| | | | | | | | | | | | | | SConnection has AccessRights property that specifies what connected client can do. Set this property to value given by SSecurity after successful authentication. This way individual SSecurity subclasses can accept clients but restrict their access.
* | Revert "Use VncAuth as the default security type, ..."Pierre Ossman2014-11-111-1/+1
| | | | | | | | | | | | | | | | This reverts commit 39d7dc043afcf6f94b9c16942765fdb9a6a3202e. We should be secure by default, even if it might cause a performance hit. Those who wish to make that trade off are more likely to notice the lack of performance than others noticing the lack of security.
* | Always log chosen security typePierre Ossman2014-11-113-3/+3
|/ | | | | It's often useful to see if encryption was used, and how the user authenticated (if at all).
* Remove unused variablePierre Ossman2014-10-281-1/+0
|
* Remove verbose TLS loggingPierre Ossman2014-10-282-26/+0
| | | | | We don't even log this much for RFB protocol stuff, and it makes it very annoying to run with full debugging on.
* Merge branch 'assert' of https://github.com/CendioOssman/tigervncPierre Ossman2014-10-103-4/+0
|\
| * Remove unused assert.h includePierre Ossman2014-10-103-4/+0
| |
* | Wrong padding size calculated (copy-paste error)Pierre Ossman2014-10-091-1/+1
|/
* Fix endian conversionPierre Ossman2014-09-251-12/+22
| | | | This was just plain wrong, so redo it properly.
* Add pixel conversion correctness testPierre Ossman2014-09-251-0/+6
|
* PixelTransformer is gone so we can protect these nowPierre Ossman2014-09-251-2/+1
|
* Move preferred encoding tracking into a server objectPierre Ossman2014-09-185-11/+29
| | | | | | Having it in ConnParams made the linker pull all the encoder objects into vncviewer, making it larger than necessary and giving it extra parameters in its help output that weren't relevant.
* Correct naming convention for some parametersPierre Ossman2014-09-174-13/+15
|
* Give a correct list of valid security schemesPierre Ossman2014-09-172-2/+10
|
* Move image encoding logic into a central EncodeManager classPierre Ossman2014-07-1434-1603/+2248
| | | | | | | | This allows us to apply a lot more server logic independently of which encoder is in use. Most of this class are things moved over from the Tight encoder.
* Remove PixelTransformer and TransImageGetterPierre Ossman2014-07-147-682/+0
| | | | There is nothing using these classes anymore, so remove the clutter.
* Use PixelBuffer objects as the interface for encoders and decodersPierre Ossman2014-07-1437-169/+154
| | | | | | | This avoid a lot of unnecessary middle men. This also pushes the responsibility for pixel format conversion into the encoders and decoders. The new bufferFromBuffer() is used for direct conversion, rather than PixelTransformer/TransImageGetter.
* Store the mouse cursor in the ConnParams objectPierre Ossman2014-07-146-118/+153
| | | | | | Like we do for everything else. This also gets rid of the callback, which is a bit out of place compared to everything else.
* Allow PixelBuffers to be constPierre Ossman2014-07-144-15/+17
|
* Add helper class for a rendered cursorPierre Ossman2014-07-145-25/+74
| | | | | | Add a magical cursor framebuffer class for handling when you want to render the cursor on the server side. Keeps the cursor specific magic in one contained place.
* Add convenience variant of getImage()Pierre Ossman2014-07-142-0/+25
|
* Add convenience functions to ModifiablePixelBufferPierre Ossman2014-07-092-0/+29
| | | | | Allows you to modify the buffer with data in a different pixel format.
* Add optimised buffer conversionPierre Ossman2014-07-093-0/+291
| | | | | | | | | Handles the common cases when the target or source are in the preferred 888 format. If one of the buffers is not 888, then it must also be properly aligned (which is commonly the case). Performance is now in many cases on par with PixelTransformer.
* Add ability to directly convert between two pixel formatsPierre Ossman2014-07-092-0/+58
| | | | | This is a lot easier and cheaper than having to set up a complete PixelTransformer object.
* Use lookup tables for pixel upconversionPierre Ossman2014-07-093-44/+64
| | | | | | You have to loop many times when converting e.g. 2 bits to 8, so have a couple of lookup tables to speed things up. We still use bit replication to get from 8 bits to 16 bits though.
* Only grab the regions we actually needPierre Ossman2014-07-071-22/+33
| | | | | Allows pixel buffers that do damage tracking to get proper information.
* Provide a better R/W base PixelBuffer classPierre Ossman2014-07-073-26/+89
| | | | | Clearly separates the read API from the write API and also from actual implementation.
* Get rid of getStride()Pierre Ossman2014-07-072-14/+11
| | | | | | It was confusing and not properly used everywhere. Callers should use the stride they get when they get the buffer pointer.
* Get rid of the direct access abuse of FullFramePixelBuffer's dataPierre Ossman2014-07-076-17/+29
|
* We don't need a fillRect() that is this optimisedPierre Ossman2014-07-072-83/+19
| | | | | Keep things simple instead and allows us to remove the extra setPF() methods.
* Avoid having virtual methods where not neededPierre Ossman2014-07-072-17/+10
|
* getImage() doesn't need to be overloadable, keep it simplePierre Ossman2014-07-073-38/+5
|
* Encoders/decoders should track the connection objectPierre Ossman2014-07-0734-109/+102
| | | | | | The connection object is a much more appropriate object for the decoders and encoders to keep track of. Besides the streams, it also contains state like connection parameters.
* Push encoder and decoder handling down into the connection objectsPierre Ossman2014-07-079-140/+57
| | | | | This keeps the reader and writer objects clean and simple protocol decoders/encoders.
* Remove full support for colour mapsPierre Ossman2014-07-0726-853/+240
| | | | | | | | | Gets rid of a loooot of code and complexity. Colour map clients are still supported through an automatically generated map, but we lose the ability to develop a client or server that uses colour maps internally.
* Get rid of unnecessary macros as they are only ever set to a single thingPierre Ossman2014-07-0715-85/+30
|
* Push encoding specific formats into the encoders and decodersPierre Ossman2014-07-0710-15/+91
| | | | Keep the generic stream classes clean and general.
* Consolidate the different palette handler implementationsPierre Ossman2014-07-078-493/+272
|
* Handle CopyRect like any other encodingPierre Ossman2014-07-077-21/+86
| | | | Avoids having to special case things. Keeps the code simpler.
* Avoid reader/writer duplication in every encoder/decoderPierre Ossman2014-07-0724-26/+27
|
* Remove partial update functionalityPierre Ossman2014-07-0715-80/+46
| | | | | | Get rid of the ability of encoders to only send part of the rectangle they are given as we don't want partial updates anyway.
* Move serialisation of pseudorects into separate functionsPierre Ossman2014-07-072-69/+72
| | | | Keeps the code clearer.
* Merge the "V3" message classes into the normal onesPierre Ossman2014-07-0720-1140/+818
| | | | We have no need for this abstraction so let's keep things simple.
* Merge branch 'pixeltest' of https://github.com/CendioOssman/tigervncPierre Ossman2014-07-071-1/+1
|\
| * librfb needs librdr so make sure it always gets pulled inPierre Ossman2014-07-041-1/+1
| |
* | Remove a lot of platform compatibilty stuffPierre Ossman2014-07-0712-132/+0
| | | | | | | | It's either not used, or no longer relevant.
* | Fix some offenders that poke around in the PixelFormat internalsPierre Ossman2014-07-073-60/+47
| |
* | Avoid code duplication for the linear pixel format conversion methodsPierre Ossman2014-07-071-79/+2
| |
* | Consistent use of stride vs pitchPierre Ossman2014-07-076-23/+24
| | | | | | | | | | | | | | Consistently use the term stride rather than pitch. Also consistently represent the stride in number of pixels rather than number of bytes. There is so much code that assumes proper alignment already that we do not need the extra resolution.