summaryrefslogtreecommitdiffstats
path: root/common/rfb
Commit message (Collapse)AuthorAgeFilesLines
...
* | Make sure Exceptions do not use unsafe format stringsPierre Ossman2015-03-034-12/+12
| |
* | Remove unused variablesPierre Ossman2015-03-035-8/+1
| |
* | Default compression level should be interpreted as highPierre Ossman2015-02-131-1/+1
| |
* | Be more aggressive in finding solid rectanglesPierre Ossman2015-02-132-74/+96
| | | | | | | | | | The previous FIXME was incorrect. The old code did in fact continue looking over the entire area. This commit restores that old behaviour.
* | Move encoder statistics into EncodeManager from SMsgWriterPierre Ossman2015-02-134-47/+168
| | | | | | | | It knows more details so it can track things better.
* | Optimise fillRect()Pierre Ossman2015-02-131-6/+26
| | | | | | | | | | It had regressed in performance compared to 1.3. This brings it back up to the same speed.
* | rfb::Region uses the Xregion libraryPierre Ossman2015-02-131-1/+1
| |
* | No need for this array to be writeablePierre Ossman2015-02-134-4/+4
| |
* | Move reverse connection information into VNCSConnectionSTPierre Ossman2015-02-134-5/+4
| | | | | | | | | | The only class that cares if connections are reversed or not is VNCSConnectionST so let it keep track of this fact.
* | These methods aren't critical so no need for them to be purePierre Ossman2015-02-132-2/+10
| |
* | Give subclasses the ability to overwrite the reader and writerPierre Ossman2015-02-132-0/+6
| | | | | | | | Needed for some tests.
* | SConnection internals should be private, just like for CConnectionPierre Ossman2015-02-131-0/+2
| |
* | Make the calls to va_list logging functions more explicitPierre Ossman2015-01-301-1/+1
|/ | | | | On some platforms va_list might be defined as something that causes ambiguity and results in the wrong function being called.
* More debug logging for screen layout changesPierre Ossman2015-01-261-7/+13
|
* Remove logging of each Timer firingPierre Ossman2015-01-261-1/+0
| | | | | It just adds noise and you can't really tell which timer it is anyway without more logging in other places.
* Restructure Xvnc/libvnc.so code to avoid C++ header hacksPierre Ossman2015-01-264-4/+18
| | | | | | | | The internal Xorg headers are very incompatible with C++ and we've had to resort to all kinds of hacks in order to include them in our C++ code. This approach isn't really viable long term so restructure things so that we have a glue layer written in C that bridges the Xorg core with the RFB classes.
* Allow LogWriter objects to be used with va_list argumentPierre Ossman2015-01-261-0/+4
|
* Make sure attributes propagate through security wrappersPierre Ossman2014-12-024-2/+34
| | | | | | Both SSecurityVeNCrypt and SSecurityStack are wrappers around other security objects, so they need to delegate the properties of those sub-objects properly.
* Limit access to non-shared modePierre Ossman2014-12-023-1/+4
| | | | | | A read-only client should not be allowed to kick out other clients. It will be forced into shared mode, or refused the connection, depending on the neverShared parameter.
* Merge branch 'readonlypassword' of https://github.com/michalsrb/tigervnc ↵Pierre Ossman2014-12-0210-46/+80
|\ | | | | | | into viewonly
| * Update comment of VncAuthPasswdGetter::getVncAuthPasswd.Michal Srb2014-11-241-2/+2
| |
| * Add AccessSetDesktopSize right.Michal Srb2014-11-245-14/+24
| | | | | | | | So clients with limited access rights can not affect it.
| * VncAuth: Read and use readonly password.Michal Srb2014-11-102-25/+47
| | | | | | | | | | Try to read second password (for read only access) from rfbauth file. If client sent second password instead of first one, allow him read only access.
| * Allow SSecurity to specify AccessRights for SConnection.Michal Srb2014-11-105-5/+7
| | | | | | | | | | | | | | SConnection has AccessRights property that specifies what connected client can do. Set this property to value given by SSecurity after successful authentication. This way individual SSecurity subclasses can accept clients but restrict their access.
* | Revert "Use VncAuth as the default security type, ..."Pierre Ossman2014-11-111-1/+1
| | | | | | | | | | | | | | | | This reverts commit 39d7dc043afcf6f94b9c16942765fdb9a6a3202e. We should be secure by default, even if it might cause a performance hit. Those who wish to make that trade off are more likely to notice the lack of performance than others noticing the lack of security.
* | Always log chosen security typePierre Ossman2014-11-113-3/+3
|/ | | | | It's often useful to see if encryption was used, and how the user authenticated (if at all).
* Remove unused variablePierre Ossman2014-10-281-1/+0
|
* Remove verbose TLS loggingPierre Ossman2014-10-282-26/+0
| | | | | We don't even log this much for RFB protocol stuff, and it makes it very annoying to run with full debugging on.
* Merge branch 'assert' of https://github.com/CendioOssman/tigervncPierre Ossman2014-10-103-4/+0
|\
| * Remove unused assert.h includePierre Ossman2014-10-103-4/+0
| |
* | Wrong padding size calculated (copy-paste error)Pierre Ossman2014-10-091-1/+1
|/
* Fix endian conversionPierre Ossman2014-09-251-12/+22
| | | | This was just plain wrong, so redo it properly.
* Add pixel conversion correctness testPierre Ossman2014-09-251-0/+6
|
* PixelTransformer is gone so we can protect these nowPierre Ossman2014-09-251-2/+1
|
* Move preferred encoding tracking into a server objectPierre Ossman2014-09-185-11/+29
| | | | | | Having it in ConnParams made the linker pull all the encoder objects into vncviewer, making it larger than necessary and giving it extra parameters in its help output that weren't relevant.
* Correct naming convention for some parametersPierre Ossman2014-09-174-13/+15
|
* Give a correct list of valid security schemesPierre Ossman2014-09-172-2/+10
|
* Move image encoding logic into a central EncodeManager classPierre Ossman2014-07-1434-1603/+2248
| | | | | | | | This allows us to apply a lot more server logic independently of which encoder is in use. Most of this class are things moved over from the Tight encoder.
* Remove PixelTransformer and TransImageGetterPierre Ossman2014-07-147-682/+0
| | | | There is nothing using these classes anymore, so remove the clutter.
* Use PixelBuffer objects as the interface for encoders and decodersPierre Ossman2014-07-1437-169/+154
| | | | | | | This avoid a lot of unnecessary middle men. This also pushes the responsibility for pixel format conversion into the encoders and decoders. The new bufferFromBuffer() is used for direct conversion, rather than PixelTransformer/TransImageGetter.
* Store the mouse cursor in the ConnParams objectPierre Ossman2014-07-146-118/+153
| | | | | | Like we do for everything else. This also gets rid of the callback, which is a bit out of place compared to everything else.
* Allow PixelBuffers to be constPierre Ossman2014-07-144-15/+17
|
* Add helper class for a rendered cursorPierre Ossman2014-07-145-25/+74
| | | | | | Add a magical cursor framebuffer class for handling when you want to render the cursor on the server side. Keeps the cursor specific magic in one contained place.
* Add convenience variant of getImage()Pierre Ossman2014-07-142-0/+25
|
* Add convenience functions to ModifiablePixelBufferPierre Ossman2014-07-092-0/+29
| | | | | Allows you to modify the buffer with data in a different pixel format.
* Add optimised buffer conversionPierre Ossman2014-07-093-0/+291
| | | | | | | | | Handles the common cases when the target or source are in the preferred 888 format. If one of the buffers is not 888, then it must also be properly aligned (which is commonly the case). Performance is now in many cases on par with PixelTransformer.
* Add ability to directly convert between two pixel formatsPierre Ossman2014-07-092-0/+58
| | | | | This is a lot easier and cheaper than having to set up a complete PixelTransformer object.
* Use lookup tables for pixel upconversionPierre Ossman2014-07-093-44/+64
| | | | | | You have to loop many times when converting e.g. 2 bits to 8, so have a couple of lookup tables to speed things up. We still use bit replication to get from 8 bits to 16 bits though.
* Only grab the regions we actually needPierre Ossman2014-07-071-22/+33
| | | | | Allows pixel buffers that do damage tracking to get proper information.
* Provide a better R/W base PixelBuffer classPierre Ossman2014-07-073-26/+89
| | | | | Clearly separates the read API from the write API and also from actual implementation.