| Commit message (Collapse) | Author | Age | Files | Lines |
| |
|
| |
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
* Added Griddragger.
* Refactored the GridDragger to match FW style
Unit tests, Test UI and documentation to come next.
* Change DropMode to BETWEEN and add Test UIs
* Simplify GridDragger API
* Fixes and unit tests for GridDragger
Fixed issues regarding drop index calculation when sourche and target grid is the same.
When the ListDataProvider is not internally using List, always drops to the end.
Updates the old data provider instead of creating a new one to preserve filters&sorting.
|
| |
|
| |
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
* Add new drop mode ON_GRID for GridDropTarget
Also adds a way to not accept drops on rows when the user has sorted the grid.
This way the bad UX can be avoided for showing the drop indicator for the wrong place when the grid has been sorted.
This has not been made default behavior to GridDropTarget since it would change behavior compared to 8.1.
Instead if is triggerable via API in GridDropTarget.
* Refactor sorted grid drop logic to server side
* Block setDropMode calls
Blocking setDropMode set values if the grid has been sorted and drop on
sorted rows is not allowed. The value is used once the grid is not sorted
anymore or the drops are allowed on sorted rows.
|
|
|
| |
Fixes #10195
|
|
|
| |
Fixes #9210
|
| |
|
|
|
|
| |
UIDL might contain sensitive information that we should prevent from
being stored anywhere.
|
|
|
|
| |
constructor, fixes undefined enum value access in VTooltip.setTooltipText
|
| |
|
| |
|
| |
|
|
|
| |
Fixes #10292
|
|
|
| |
From VDateField and VWindow
|
|
|
| |
Based on vaadin/flow#2834
|
|
|
| |
Make focus circulate in modal dialog to improve accessibility
|
|
|
|
|
|
|
|
|
| |
* HasItems.setItems(T... items) should allow edits
Arrays.asList() creates a immutable Arrays.ArrayList, preventing users from doing dataProvider.getItems() and updating the returned collection. This makes it impossible to keep the same data provider, update it and keep the filters & sorting, and then just call dataProvider.refreshAll() to get changes visible. We should not require users to create a new data provider in this case.
This is the same for DataProvider.ofItems(T... items)
* fix missing whitespace from test error message
|
|
|
|
|
|
|
|
| |
* Relax TreeGrid and Tree members access modifiers.
Fixes #10292
* Fixes after review
|
|
|
| |
Because VConsole is deprecated and it recommends using Logger instead
|
| |
|
| |
|
| |
|
| |
|
|
|
|
|
| |
In some places, getWidget() is called many times, and I believe this can
have a litte performance improvement, since in some cases
super.getWidget() is called more than once.
|
| |
|
| |
|
|
|
| |
Fixes #10214
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
* add Grid#Column#get/setAssistiveCaption
* fix test and update doc
* move testGridAssistiveCaption to GridTest
* delete test file
* delete test file
* Delete GridAssistiveCaptionTest.java
* Create GridAssistiveCaptionTest
* Create GridAssistiveCaption
* Rename GridAssistiveCaption to GridAssistiveCaption.java
* Rename GridAssistiveCaptionTest to GridAssistiveCaptionTest.java
* Reformat using eclipse
|
|
|
| |
Also improve naming by replacing one-letter variable names.
|
|
|
| |
Also use "event" as the name for events
|
|
|
|
|
| |
* Variable names to conform to naming convention.
* Use static constants where it makes sense
|
| |
|
|
|
|
|
|
|
|
|
|
| |
* Add contribution guideline
* Make suggested improvements to CONTRIBUTING.md
* Add link to good first issues and project setup
* Small update to CONTRIBUTING.md
|
|
|
|
|
|
| |
* adds simple fix for missing label text in grid select checkboxes
* updated comment and wording
|
|
|
|
|
|
| |
* Fix bad grammar in declarative documentation
* Fix typos
|
|
|
|
|
|
|
|
| |
* Unlock panel caption div hacking
Fixes #10119
* Javadoc formatting fix
|
|
|
|
|
|
|
|
|
|
|
| |
* Grid column to be sortable when implemented/supported
* Fix GridDeclarativeTest
* Parameterize to Grid<Person>
* Revert Parameterize to Grid<Person>, JDK with generics.
* Assertions for other columns
* Fix test
Fixes #8792
|
|
|
|
|
|
|
|
|
|
| |
* Grid.removeColumn() not to fail silently (Fixes #8056)
* Compilation with JDK
* Fix removeColumnByColumn_alreadyRemoved test
* Use ExpectedException
|
|
|
| |
Remove "java" from code example
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
* AbstractDateField.formatDate to be abstract
Remove invalidDateString paramter, as it can be deduced
* Fix test
* Remove AbstractDateField.getResolutionVariable
VAbstractTextualDate: rename updateDateVariables() to updateBufferedResolutions()
* Revert to use fixed value of MONDAY.
* release notes
* updateAndSendBufferedValues()
* Missed call to updateAndSendBufferedValues();
* release note
|
|
|
|
|
|
|
|
|
| |
* Added the possiblity of defining a Field as Required without
setting an error message.
* Added @since to asRequired()
* Add droped paragraphs and see tag for asRequired(String)
|
|
|
|
|
|
| |
* Fix typos
* Fix
|
|
|
|
|
|
|
|
|
|
| |
* Check whether className is of type string
* Move string type checker method to widget util
* Fix formatting of WidgetUtil
* Break svg into lines
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
* add role="row" and role="gridcell"
* optimize code and add additional rows for the header
* add simple test
* improve code and add rowgroup
* add debug log
* add more log to test
* remove debug test info and add role before appending to tr
* wording - change contains to contain
* create enum for magic strings, change comments and method signature
* rename enum to be singular and rename param roleName to role
* update javadoc, rename and make enum public
|
|
|
|
|
|
|
|
| |
* Use .toLowerCase and .toUpperCase(Locale.ROOT)
* Spaces
* add spaces after if(
|
| |
|
|
|
|
|
|
|
|
| |
* Fix HTML tags inside code in javadoc
* only modify <table> and <tr>
* Fix javadoc
|
|
|
|
|
|
|
|
| |
* Scheduler.ScheduledCommand and RepeatingCommand to be lambda
* Restore <table> in javadoc
* Fix docs
|