| Commit message (Expand) | Author | Age | Files | Lines |
* | Vaadin 8 terminology changes: Architecture Overviewfeature/vaadin8-book | Johannes Dahlström | 2016-07-13 | 0 | -0/+0 |
* | Revised diagrams in intro, installation, architecture, and application chapte... | Marko Gronroos | 2016-07-13 | 47 | -16032/+9167 |
* | Vaadin 8 terminology changes: Architecture Overview | Johannes Dahlström | 2016-07-13 | 1 | -8/+5 |
* | Move shared classes to a temporary subpackage | Teemu Suo-Anttila | 2016-07-13 | 22 | -32/+30 |
* | Add sortingBy with function parameter to in-memory data source | Teemu Suo-Anttila | 2016-07-12 | 2 | -2/+23 |
* | Add additional checks to in-memory data source tests | Teemu Suo-Anttila | 2016-07-12 | 1 | -1/+12 |
* | Add basic sorting implementation and API | Teemu Suo-Anttila | 2016-07-12 | 10 | -43/+142 |
* | Simplify DataSource to be a function that provides Stream of values | Teemu Suo-Anttila | 2016-07-12 | 8 | -388/+92 |
* | Fix dropped key clean up in DataCommunicatorConnector | Teemu Suo-Anttila | 2016-07-12 | 1 | -0/+1 |
* | Rename data communication class to DataCommunicator | Teemu Suo-Anttila | 2016-07-12 | 8 | -50/+50 |
* | Fix ARS to find tests from temp package | Teemu Suo-Anttila | 2016-07-12 | 1 | -0/+2 |
* | Clean up NativeSelectConnector update logic | Teemu Suo-Anttila | 2016-07-11 | 1 | -78/+50 |
* | Use a lazy-loading compatible client-side data source with listings | Teemu Suo-Anttila | 2016-07-11 | 12 | -401/+342 |
* | Move new files under temporary package names | Teemu Suo-Anttila | 2016-07-11 | 46 | -143/+134 |
* | Rename Component.Event to LegacyEvent | Johannes Dahlström | 2016-07-07 | 39 | -89/+91 |
* | Rename package c.v.event.handler to c.v.event.typed | Johannes Dahlström | 2016-07-07 | 14 | -32/+30 |
* | Unify onChange event handling | Johannes Dahlström | 2016-07-07 | 10 | -214/+175 |
* | Fix for checkbox read-only (#19971) | elmot | 2016-06-21 | 1 | -3/+1 |
* | Fix typos in Javadoc; Optimize imports; Minor change for code style | elmot | 2016-06-21 | 3 | -8/+3 |
* | Fix null as a SelectionModel | Teemu Suo-Anttila | 2016-06-17 | 11 | -130/+185 |
* | Implement a new DateField based on LocalDate | Teemu Suo-Anttila | 2016-06-17 | 4 | -0/+280 |
* | Make onChange throw in TextField and CheckBox when Handler is null | Aleksi Hietanen | 2016-06-17 | 2 | -0/+59 |
* | Add setOptions to Listing with default implementation | Teemu Suo-Anttila | 2016-06-16 | 1 | -0/+21 |
* | Implement a new typed Grid | Teemu Suo-Anttila | 2016-06-16 | 10 | -28/+415 |
* | Change DataSource addDataChangeHandler() return type to Registration | Aleksi Hietanen | 2016-06-16 | 3 | -21/+15 |
* | Add ListDataSource with tests | Teemu Suo-Anttila | 2016-06-16 | 4 | -1/+193 |
* | Implement onChange handlers in SingleSelection | Aleksi Hietanen | 2016-06-16 | 2 | -5/+25 |
* | Fix select null in SingleSelection | Teemu Suo-Anttila | 2016-06-16 | 1 | -1/+3 |
* | Add Binder for binding beans to fields | Teemu Suo-Anttila | 2016-06-16 | 2 | -0/+256 |
* | Implement new TextField | Johannes Dahlström | 2016-06-16 | 5 | -0/+509 |
* | Implement a new typed CheckBox | Teemu Suo-Anttila | 2016-06-15 | 2 | -0/+299 |
* | Use DataProviderConstants for communication | Teemu Suo-Anttila | 2016-06-15 | 3 | -11/+18 |
* | Extract a base class from typed NativeSelect | Teemu Suo-Anttila | 2016-06-15 | 7 | -120/+341 |
* | Add server to client communication to selection model | Teemu Suo-Anttila | 2016-06-15 | 11 | -11/+156 |
* | Add typed NativeSelect and SelectionModel functionality | Teemu Suo-Anttila | 2016-06-15 | 12 | -3/+746 |
* | Add a DataProvider implementation | Teemu Suo-Anttila | 2016-06-15 | 9 | -0/+1012 |
* | Introduce Listing and SelectionModel | Teemu Suo-Anttila | 2016-06-15 | 2 | -0/+153 |
* | Add DataSource interface with abstract base class | Teemu Suo-Anttila | 2016-06-15 | 3 | -0/+224 |
* | Initial HasValue, Handler, Event and Registration | Teemu Suo-Anttila | 2016-06-15 | 4 | -0/+208 |
* | Update version number, use Java 8 | Teemu Suo-Anttila | 2016-06-15 | 15 | -18/+18 |
* | Provide a way to disallow navigation to the same state twice (#12107). | Denis Anisimov | 2016-06-13 | 2 | -26/+121 |
* | Added a note to JPAContainer chapter that it is no longer recommended. | Marko Gronroos | 2016-06-10 | 1 | -5/+6 |
* | Fixed wrong font include. | Sami Ekblad | 2016-06-10 | 1 | -1/+1 |
* | Unneeded duplicate of the word "should" | Vlad | 2016-06-09 | 1 | -1/+1 |
* | Fixing messed up column in Grid after hide, resize and show (#19826) | adam | 2016-06-07 | 3 | -1/+181 |
* | Add missing license header to BodyStyleName | Teemu Suo-Anttila | 2016-06-03 | 1 | -0/+16 |
* | Suppress Checkstyle markers from */target/* paths | Johannes Dahlström | 2016-06-03 | 3 | -1/+11 |
* | Fix a Javadoc typo that crashes Checkstyle (yes, really) | Johannes Dahlström | 2016-06-02 | 1 | -1/+1 |
* | Add missing @since 7.77.7.0.alpha3 | Henri Sara | 2016-06-01 | 1 | -1/+1 |
* | New login form (#8171) | Ingo Kegel | 2016-06-01 | 7 | -232/+566 |