Commit message (Collapse) | Author | Age | Files | Lines | |
---|---|---|---|---|---|
* | Update since tags in JavaDoc (#10325)8.2.0.alpha3 | Teemu Suo-Anttila | 2017-11-15 | 4 | -9/+9 |
| | |||||
* | Add new drop mode ON_GRID for GridDropTarget (#10296) | Pekka Hyvönen | 2017-11-15 | 3 | -3/+16 |
| | | | | | | | | | | | | | | | | | * Add new drop mode ON_GRID for GridDropTarget Also adds a way to not accept drops on rows when the user has sorted the grid. This way the bad UX can be avoided for showing the drop indicator for the wrong place when the grid has been sorted. This has not been made default behavior to GridDropTarget since it would change behavior compared to 8.1. Instead if is triggerable via API in GridDropTarget. * Refactor sorted grid drop logic to server side * Block setDropMode calls Blocking setDropMode set values if the grid has been sorted and drop on sorted rows is not allowed. The value is used once the grid is not sorted anymore or the drops are allowed on sorted rows. | ||||
* | Fix setting custom tab index for TabSheet or Accordion (#9574) (#10278) | Ansku | 2017-11-10 | 1 | -0/+1 |
| | |||||
* | Add ContentMode for row and cell descriptions in Grid (#10282) | Teemu Suo-Anttila | 2017-11-10 | 2 | -6/+28 |
| | |||||
* | Fix javadoc ending (#10274) | Ahmed Ashour | 2017-11-06 | 3 | -3/+3 |
| | |||||
* | Remove redundant interface already implemented by super class. (#10258) | Ahmed Ashour | 2017-10-31 | 10 | -21/+10 |
| | |||||
* | add Grid.Column#get/setAssistiveCaption (#10219) | Knoobie | 2017-10-30 | 1 | -0/+3 |
| | | | | | | | | | | | | | | | | | | | | | | | | * add Grid#Column#get/setAssistiveCaption * fix test and update doc * move testGridAssistiveCaption to GridTest * delete test file * delete test file * Delete GridAssistiveCaptionTest.java * Create GridAssistiveCaptionTest * Create GridAssistiveCaption * Rename GridAssistiveCaption to GridAssistiveCaption.java * Rename GridAssistiveCaptionTest to GridAssistiveCaptionTest.java * Reformat using eclipse | ||||
* | Improve naming of fields and variables (#10242) | Ahmed Ashour | 2017-10-26 | 2 | -6/+6 |
| | | | | | * Variable names to conform to naming convention. * Use static constants where it makes sense | ||||
* | Remove trailing spaces (#10224) | Ahmed Ashour | 2017-10-26 | 19 | -35/+35 |
| | |||||
* | Grid column to be sortable when implemented/supported (Fixes #8792). (#10190) | Ahmed Ashour | 2017-10-23 | 1 | -2/+2 |
| | | | | | | | | | | | * Grid column to be sortable when implemented/supported * Fix GridDeclarativeTest * Parameterize to Grid<Person> * Revert Parameterize to Grid<Person>, JDK with generics. * Assertions for other columns * Fix test Fixes #8792 | ||||
* | AbstractDateField.formatDate() to be abstract (#10186) | Ahmed Ashour | 2017-10-20 | 1 | -7/+5 |
| | | | | | | | | | | | | | | | | | | | | | | * AbstractDateField.formatDate to be abstract Remove invalidDateString paramter, as it can be deduced * Fix test * Remove AbstractDateField.getResolutionVariable VAbstractTextualDate: rename updateDateVariables() to updateBufferedResolutions() * Revert to use fixed value of MONDAY. * release notes * updateAndSendBufferedValues() * Missed call to updateAndSendBufferedValues(); * release note | ||||
* | Use .toLowerCase and .toUpperCase(Locale.ROOT) (#10182) | Ahmed Ashour | 2017-10-20 | 4 | -12/+16 |
| | | | | | | | | * Use .toLowerCase and .toUpperCase(Locale.ROOT) * Spaces * add spaces after if( | ||||
* | Fix IDE usage of Elemental in vaadin-shared (#10178) | Teemu Suo-Anttila | 2017-10-16 | 1 | -0/+21 |
| | |||||
* | Fix some checkstyle warnings (#10179) | Ahmed Ashour | 2017-10-13 | 1 | -2/+4 |
| | |||||
* | Convert AbstractDateField not to be a LegacyComponent (#10148) | Ahmed Ashour | 2017-10-13 | 3 | -26/+107 |
| | |||||
* | Fix typos (#10158) | Ahmed Ashour | 2017-10-10 | 1 | -1/+1 |
| | |||||
* | Edit grid row by index - server side (#10040) | Piotr Wilkin | 2017-10-10 | 1 | -0/+9 |
| | | | | | Opening grid editor from server side. Fixes #8477. Addressing #8820 will be the user's responsibility as fetching index of item might be slow. | ||||
* | Add empty line at the end of files (#10142) | Ahmed Ashour | 2017-10-06 | 1 | -1/+1 |
| | |||||
* | Fix typos (#10124) | Ahmed Ashour | 2017-10-04 | 1 | -9/+10 |
| | |||||
* | Registration to remove state.registeredEventListeners (fixes #9634) (#10130) | Ahmed Ashour | 2017-10-04 | 2 | -12/+26 |
| | | | This changes SharedState.registeredEventListeners to be a Map that keeps track of how many listeners of each type have been added, and handles unregistering of such listeners correctly. | ||||
* | Use static import of Assert in tests (#10126) | Ahmed Ashour | 2017-10-03 | 1 | -60/+53 |
| | | | | Also removes dependency on junit.framework.TestCase . | ||||
* | Use enhanced for loop for arrays. (#10121) | Ahmed Ashour | 2017-10-02 | 1 | -2/+2 |
| | |||||
* | First sentence of javadoc should end with a period (#10114) | Ahmed Ashour | 2017-10-02 | 28 | -73/+76 |
| | | | Also includes minor other javadoc and formatting fixes. | ||||
* | Handle 'z' (timezone) in AbstractDateField.setDateFormat() (#8844) | Ahmed Ashour | 2017-09-28 | 1 | -6/+14 |
| | |||||
* | Update empty since tags for 8.2 (#10107) | Henri Sara | 2017-09-28 | 4 | -12/+12 |
| | |||||
* | Support addCloseListener for Notification (#10027) | Ahmed Ashour | 2017-09-27 | 3 | -16/+91 |
| | | | | | Converts Notification to an Extension and adds support for listening to the closing of notifications. Fixes #888 | ||||
* | Convert Embedded not to be a LegacyComponent (#10088) | Ahmed Ashour | 2017-09-27 | 2 | -25/+72 |
| | |||||
* | Add option to use PushState instead of URI fragments in Navigator (#10042) | Teemu Suo-Anttila | 2017-09-27 | 1 | -0/+9 |
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Navigator now by default uses pushState and normal URLs * added documentation for pushState and updated Navigator documentation * improving docs etc, adding one TODO to be solved before merging * pushState/replaceState no work better with changing titles * Making uri fragment navigator work when not using specially mapped UI * Revert to older default, add annotation for selecting * Fix tests, add null checks * Reorder if-clause, fix tests * Revert unnecessary test change * Use correct variable in UI, fix test clean up * Updates to JavaDocs, fix some methods and tests * Add comments, fix test ui, TODO for fallbacks * Navigation documentation, JavaDocs, removed TODOs * Documentation fixes * Improve JavaDocs * Fix link name in documentation * Improve throws declaration in getLocation * Change documentation about the PushState based navigation * Add since tags * Add since tags for UI | ||||
* | Implement error level on client side (#9817) | Adam Wagner | 2017-09-27 | 3 | -3/+77 |
| | | | | | | | Add additional class names and style to components and error indicators to distinguish different error levels. Vaadin 8 implementation of #9816. Cherry picked changes and added compatibility package component changes and tests. Resolves #3139 | ||||
* | Remove unused @VERSION@ | Ahmed Ashour | 2017-09-25 | 3 | -3/+0 |
| | |||||
* | Fix javadoc references (#10067) | Ahmed Ashour | 2017-09-23 | 1 | -8/+6 |
| | | | And remove unused imports. | ||||
* | Replace iff with if in javadoc (#10056) | Ahmed Ashour | 2017-09-22 | 1 | -7/+7 |
| | |||||
* | Use String.isEmpty() (#10045) | Ahmed Ashour | 2017-09-21 | 1 | -1/+1 |
| | |||||
* | Remove unused methods (#10020) | Ahmed Ashour | 2017-09-20 | 1 | -10/+0 |
| | |||||
* | Use interface not Implementation, as method parameter | Ahmed Ashour | 2017-09-20 | 1 | -2/+2 |
| | |||||
* | Use simple class names | Ahmed Ashour | 2017-09-20 | 1 | -1/+1 |
| | |||||
* | Implement hashCode() when implementing equals() | Ahmed Ashour | 2017-09-19 | 1 | -1/+10 |
| | |||||
* | Use String.isEmpty() | Ahmed Ashour | 2017-09-19 | 1 | -3/+3 |
| | |||||
* | Fix bnd warnings | Ahmed Ashour | 2017-09-14 | 1 | -2/+1 |
| | |||||
* | Simplify conditional logic. | Ahmed Ashour | 2017-09-14 | 1 | -6/+3 |
| | |||||
* | Update version to 8.2-SNAPSHOT (#9946) | Teemu Suo-Anttila | 2017-09-08 | 1 | -1/+1 |
| | |||||
* | Add missing since tags for 8.2 (#9938) | Henri Sara | 2017-09-07 | 1 | -1/+1 |
| | |||||
* | Fix capitalization of single character strings (#9880) | Artur | 2017-08-28 | 2 | -1/+2 |
| | |||||
* | Create setter name in a Turkish compatible manner (#9878) | Artur | 2017-08-28 | 1 | -2/+3 |
| | |||||
* | Add item description to RadioButtonGroup and CheckBoxGroup (#9841) | Teemu Suo-Anttila | 2017-08-23 | 1 | -0/+5 |
| | |||||
* | Use correct version in since for Grid row height methods (#9824) | Teemu Suo-Anttila | 2017-08-16 | 1 | -3/+3 |
| | | | Related to #9425. | ||||
* | Provide API for setting row heights in Grid for different sections (#9810) | Teemu Suo-Anttila | 2017-08-11 | 1 | -3/+18 |
| | | | Fixes #9425 | ||||
* | Add loop and preload attributes for media elements, fix null poster (#9797) | Henri Sara | 2017-08-09 | 2 | -0/+65 |
| | | | | | | | Picked from #9161 Fixes #7261 Fixes #5178 Fixes #4409 | ||||
* | Add missing since tags for 8.1.1 (#9773)8.1.1 | Henri Sara | 2017-08-03 | 2 | -3/+8 |
| | |||||
* | Add header and footer visibility setting to Grid (#9706) | Teemu Suo-Anttila | 2017-08-01 | 1 | -0/+3 |
| |