summaryrefslogtreecommitdiffstats
path: root/shared
Commit message (Collapse)AuthorAgeFilesLines
* Rename contentMode to descriptionContentMode in MenuItem (#10494)Leif Åstrand2018-01-081-1/+1
|
* Add missing since tags and JavaDocs (#10487)8.3.0.alpha1Teemu Suo-Anttila2018-01-032-0/+9
|
* Implement widget event handling for Columns in Grid (#10412)Teemu Suo-Anttila2017-12-291-1/+1
| | | | Fixes #7833
* Add ContentMode for the description of MenuItems (#9984)Jonas Zipprick2017-12-291-0/+2
| | | | | Adds the ability to set the content mode for the description of a menu item that is part of a menu bar. This functionality was already available for every AbstractComponent but missing for the menu items of menu bars. If no content mode is specified it defaults to the PREFORMATED content mode.
* Allow setting custom styles to DateField calendar date cells (#10305)Anna Koskinen2017-12-281-0/+6
| | | Fixes #10304
* Clarify ContentMode javadocs (#10395)Leif Åstrand2017-12-011-5/+6
| | | | * Don't refer to Label * Explicitly mention XSS risk with HTML
* Update version number to 8.3-SNAPSHOT (#10348)Teemu Suo-Anttila2017-11-221-1/+1
|
* Fix issues from API review for 8.2 (#10342)Aleksi Hietanen2017-11-213-26/+13
| | | | | | | | | | | | | | | | | * Rename HierarchicalDataCommunicator#getMapper to getHierarchyMapper * Make rpc field in Notification private * Change DropIndexCalculator.ALWAYS_DROP_TO_END to a generic static method * Move EditorImpl#editRow documentation to the interface level * Correct GridDragEndEvent, GridDragStartEvent constructor javadocs * Revert SharedState.registeredEventListeners to a Set * Rename GridDropTarget dropAllowedOnSortedGridRows * Rename ColumnState.contentMode to tooltipContentMode
* Add documentation on GridDragger (#10328)Pekka Hyvönen2017-11-161-0/+3
| | | | This pathc also switches GridDragger to by default not allow drops on rows when the grid has been sorted.
* Update since tags in JavaDoc (#10325)8.2.0.alpha3Teemu Suo-Anttila2017-11-154-9/+9
|
* Add new drop mode ON_GRID for GridDropTarget (#10296)Pekka Hyvönen2017-11-153-3/+16
| | | | | | | | | | | | | | | | | * Add new drop mode ON_GRID for GridDropTarget Also adds a way to not accept drops on rows when the user has sorted the grid. This way the bad UX can be avoided for showing the drop indicator for the wrong place when the grid has been sorted. This has not been made default behavior to GridDropTarget since it would change behavior compared to 8.1. Instead if is triggerable via API in GridDropTarget. * Refactor sorted grid drop logic to server side * Block setDropMode calls Blocking setDropMode set values if the grid has been sorted and drop on sorted rows is not allowed. The value is used once the grid is not sorted anymore or the drops are allowed on sorted rows.
* Fix setting custom tab index for TabSheet or Accordion (#9574) (#10278)Ansku2017-11-101-0/+1
|
* Add ContentMode for row and cell descriptions in Grid (#10282)Teemu Suo-Anttila2017-11-102-6/+28
|
* Fix javadoc ending (#10274)Ahmed Ashour2017-11-063-3/+3
|
* Remove redundant interface already implemented by super class. (#10258)Ahmed Ashour2017-10-3110-21/+10
|
* add Grid.Column#get/setAssistiveCaption (#10219)Knoobie2017-10-301-0/+3
| | | | | | | | | | | | | | | | | | | | | | | | * add Grid#Column#get/setAssistiveCaption * fix test and update doc * move testGridAssistiveCaption to GridTest * delete test file * delete test file * Delete GridAssistiveCaptionTest.java * Create GridAssistiveCaptionTest * Create GridAssistiveCaption * Rename GridAssistiveCaption to GridAssistiveCaption.java * Rename GridAssistiveCaptionTest to GridAssistiveCaptionTest.java * Reformat using eclipse
* Improve naming of fields and variables (#10242)Ahmed Ashour2017-10-262-6/+6
| | | | | * Variable names to conform to naming convention. * Use static constants where it makes sense
* Remove trailing spaces (#10224)Ahmed Ashour2017-10-2619-35/+35
|
* Grid column to be sortable when implemented/supported (Fixes #8792). (#10190)Ahmed Ashour2017-10-231-2/+2
| | | | | | | | | | | * Grid column to be sortable when implemented/supported * Fix GridDeclarativeTest * Parameterize to Grid<Person> * Revert Parameterize to Grid<Person>, JDK with generics. * Assertions for other columns * Fix test Fixes #8792
* AbstractDateField.formatDate() to be abstract (#10186)Ahmed Ashour2017-10-201-7/+5
| | | | | | | | | | | | | | | | | | | | | | * AbstractDateField.formatDate to be abstract Remove invalidDateString paramter, as it can be deduced * Fix test * Remove AbstractDateField.getResolutionVariable VAbstractTextualDate: rename updateDateVariables() to updateBufferedResolutions() * Revert to use fixed value of MONDAY. * release notes * updateAndSendBufferedValues() * Missed call to updateAndSendBufferedValues(); * release note
* Use .toLowerCase and .toUpperCase(Locale.ROOT) (#10182)Ahmed Ashour2017-10-204-12/+16
| | | | | | | | * Use .toLowerCase and .toUpperCase(Locale.ROOT) * Spaces * add spaces after if(
* Fix IDE usage of Elemental in vaadin-shared (#10178)Teemu Suo-Anttila2017-10-161-0/+21
|
* Fix some checkstyle warnings (#10179)Ahmed Ashour2017-10-131-2/+4
|
* Convert AbstractDateField not to be a LegacyComponent (#10148)Ahmed Ashour2017-10-133-26/+107
|
* Fix typos (#10158)Ahmed Ashour2017-10-101-1/+1
|
* Edit grid row by index - server side (#10040)Piotr Wilkin2017-10-101-0/+9
| | | | | Opening grid editor from server side. Fixes #8477. Addressing #8820 will be the user's responsibility as fetching index of item might be slow.
* Add empty line at the end of files (#10142)Ahmed Ashour2017-10-061-1/+1
|
* Fix typos (#10124)Ahmed Ashour2017-10-041-9/+10
|
* Registration to remove state.registeredEventListeners (fixes #9634) (#10130)Ahmed Ashour2017-10-042-12/+26
| | | This changes SharedState.registeredEventListeners to be a Map that keeps track of how many listeners of each type have been added, and handles unregistering of such listeners correctly.
* Use static import of Assert in tests (#10126)Ahmed Ashour2017-10-031-60/+53
| | | | Also removes dependency on junit.framework.TestCase .
* Use enhanced for loop for arrays. (#10121)Ahmed Ashour2017-10-021-2/+2
|
* First sentence of javadoc should end with a period (#10114)Ahmed Ashour2017-10-0228-73/+76
| | | Also includes minor other javadoc and formatting fixes.
* Handle 'z' (timezone) in AbstractDateField.setDateFormat() (#8844)Ahmed Ashour2017-09-281-6/+14
|
* Update empty since tags for 8.2 (#10107)Henri Sara2017-09-284-12/+12
|
* Support addCloseListener for Notification (#10027)Ahmed Ashour2017-09-273-16/+91
| | | | | Converts Notification to an Extension and adds support for listening to the closing of notifications. Fixes #888
* Convert Embedded not to be a LegacyComponent (#10088)Ahmed Ashour2017-09-272-25/+72
|
* Add option to use PushState instead of URI fragments in Navigator (#10042)Teemu Suo-Anttila2017-09-271-0/+9
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Navigator now by default uses pushState and normal URLs * added documentation for pushState and updated Navigator documentation * improving docs etc, adding one TODO to be solved before merging * pushState/replaceState no work better with changing titles * Making uri fragment navigator work when not using specially mapped UI * Revert to older default, add annotation for selecting * Fix tests, add null checks * Reorder if-clause, fix tests * Revert unnecessary test change * Use correct variable in UI, fix test clean up * Updates to JavaDocs, fix some methods and tests * Add comments, fix test ui, TODO for fallbacks * Navigation documentation, JavaDocs, removed TODOs * Documentation fixes * Improve JavaDocs * Fix link name in documentation * Improve throws declaration in getLocation * Change documentation about the PushState based navigation * Add since tags * Add since tags for UI
* Implement error level on client side (#9817)Adam Wagner2017-09-273-3/+77
| | | | | | | Add additional class names and style to components and error indicators to distinguish different error levels. Vaadin 8 implementation of #9816. Cherry picked changes and added compatibility package component changes and tests. Resolves #3139
* Remove unused @VERSION@Ahmed Ashour2017-09-253-3/+0
|
* Fix javadoc references (#10067)Ahmed Ashour2017-09-231-8/+6
| | | And remove unused imports.
* Replace iff with if in javadoc (#10056)Ahmed Ashour2017-09-221-7/+7
|
* Use String.isEmpty() (#10045)Ahmed Ashour2017-09-211-1/+1
|
* Remove unused methods (#10020)Ahmed Ashour2017-09-201-10/+0
|
* Use interface not Implementation, as method parameterAhmed Ashour2017-09-201-2/+2
|
* Use simple class namesAhmed Ashour2017-09-201-1/+1
|
* Implement hashCode() when implementing equals()Ahmed Ashour2017-09-191-1/+10
|
* Use String.isEmpty()Ahmed Ashour2017-09-191-3/+3
|
* Fix bnd warningsAhmed Ashour2017-09-141-2/+1
|
* Simplify conditional logic.Ahmed Ashour2017-09-141-6/+3
|
* Update version to 8.2-SNAPSHOT (#9946)Teemu Suo-Anttila2017-09-081-1/+1
|