| Commit message (Collapse) | Author | Age | Files | Lines |
| |
|
|
|
| |
Fixes #10221
|
| |
|
| |
|
|
|
| |
Fixes #8918
|
|
|
| |
Fixes #9663
|
| |
|
|
|
|
|
|
|
| |
* Fix missing v-disabled for RadioButtonGroup
* Fix missing v-disabled for CheckBoxGroup
Resolves #9258
|
| |
|
|
|
|
| |
Deprecate com.vaadin.ui.components.grid.DescriptionGenerator
and subclass it from the new DescriptionGenerator.
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
* Rename HierarchicalDataCommunicator#getMapper to getHierarchyMapper
* Make rpc field in Notification private
* Change DropIndexCalculator.ALWAYS_DROP_TO_END to a generic static method
* Move EditorImpl#editRow documentation to the interface level
* Correct GridDragEndEvent, GridDragStartEvent constructor javadocs
* Revert SharedState.registeredEventListeners to a Set
* Rename GridDropTarget dropAllowedOnSortedGridRows
* Rename ColumnState.contentMode to tooltipContentMode
|
|
|
|
|
|
|
|
|
|
|
| |
* Accessibility for MenuBar (#3922)
* TabIndex handling fix and an indexing tweak
* Make disabled MenuItems selectable for accessibility (#3922)
- It should be possible to navigate to a disabled MenuItem, even if
triggering the related command is disabled
* Refactor primary style name and aria attribute handling to own method
|
| |
|
| |
|
|
|
| |
The old name GridDragger gave an impression that you're dragging the whole grid instead of rows.
|
|
|
|
| |
This pathc also switches GridDragger to by default not allow drops on rows when the
grid has been sorted.
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
* Added Griddragger.
* Refactored the GridDragger to match FW style
Unit tests, Test UI and documentation to come next.
* Change DropMode to BETWEEN and add Test UIs
* Simplify GridDragger API
* Fixes and unit tests for GridDragger
Fixed issues regarding drop index calculation when sourche and target grid is the same.
When the ListDataProvider is not internally using List, always drops to the end.
Updates the old data provider instead of creating a new one to preserve filters&sorting.
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
* Add new drop mode ON_GRID for GridDropTarget
Also adds a way to not accept drops on rows when the user has sorted the grid.
This way the bad UX can be avoided for showing the drop indicator for the wrong place when the grid has been sorted.
This has not been made default behavior to GridDropTarget since it would change behavior compared to 8.1.
Instead if is triggerable via API in GridDropTarget.
* Refactor sorted grid drop logic to server side
* Block setDropMode calls
Blocking setDropMode set values if the grid has been sorted and drop on
sorted rows is not allowed. The value is used once the grid is not sorted
anymore or the drops are allowed on sorted rows.
|
| |
|
| |
|
|
|
| |
Make focus circulate in modal dialog to improve accessibility
|
|
|
| |
Because VConsole is deprecated and it recommends using Logger instead
|
| |
|
|
|
|
|
| |
In some places, getWidget() is called many times, and I believe this can
have a litte performance improvement, since in some cases
super.getWidget() is called more than once.
|
| |
|
| |
|
|
|
| |
Fixes #10214
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
* add Grid#Column#get/setAssistiveCaption
* fix test and update doc
* move testGridAssistiveCaption to GridTest
* delete test file
* delete test file
* Delete GridAssistiveCaptionTest.java
* Create GridAssistiveCaptionTest
* Create GridAssistiveCaption
* Rename GridAssistiveCaption to GridAssistiveCaption.java
* Rename GridAssistiveCaptionTest to GridAssistiveCaptionTest.java
* Reformat using eclipse
|
|
|
| |
Also improve naming by replacing one-letter variable names.
|
|
|
| |
Also use "event" as the name for events
|
| |
|
|
|
|
|
|
|
|
|
|
|
| |
* Grid column to be sortable when implemented/supported
* Fix GridDeclarativeTest
* Parameterize to Grid<Person>
* Revert Parameterize to Grid<Person>, JDK with generics.
* Assertions for other columns
* Fix test
Fixes #8792
|
|
|
|
|
|
| |
* Fix typos
* Fix
|
|
|
|
|
|
|
|
|
|
| |
* Check whether className is of type string
* Move string type checker method to widget util
* Fix formatting of WidgetUtil
* Break svg into lines
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
* add role="row" and role="gridcell"
* optimize code and add additional rows for the header
* add simple test
* improve code and add rowgroup
* add debug log
* add more log to test
* remove debug test info and add role before appending to tr
* wording - change contains to contain
* create enum for magic strings, change comments and method signature
* rename enum to be singular and rename param roleName to role
* update javadoc, rename and make enum public
|
|
|
|
|
|
|
|
| |
* Use .toLowerCase and .toUpperCase(Locale.ROOT)
* Spaces
* add spaces after if(
|
|
|
|
|
|
|
|
| |
* Scheduler.ScheduledCommand and RepeatingCommand to be lambda
* Restore <table> in javadoc
* Fix docs
|
|
|
|
|
|
|
|
| |
* Add spaces after 'if' and 'for' in JavaScript
* Revert to old format
* Remove whitespaces
|
|
|
|
|
|
|
|
| |
* Simplify lambda expressions
And remove unneeded 'return' keyword.
* Format
|
|
|
|
| |
Fixes #9763
Fixes #9978
|
|
|
| |
Fixes #9200
|
| |
|
| |
|
|
|
| |
Fixes #9792
|
|
|
| |
This is based on discussion from vaadin/vaadin-grid#1023 .
|
|
|
| |
Fixes #10038
|
| |
|
| |
|
|
|
|
|
| |
Opening grid editor from server side.
Fixes #8477.
Addressing #8820 will be the user's responsibility as fetching index of item might be slow.
|
| |
|