summaryrefslogtreecommitdiffstats
path: root/uitest
Commit message (Collapse)AuthorAgeFilesLines
...
* Add new drop mode ON_GRID for GridDropTarget (#10296)Pekka Hyvönen2017-11-151-1/+8
| | | | | | | | | | | | | | | | | * Add new drop mode ON_GRID for GridDropTarget Also adds a way to not accept drops on rows when the user has sorted the grid. This way the bad UX can be avoided for showing the drop indicator for the wrong place when the grid has been sorted. This has not been made default behavior to GridDropTarget since it would change behavior compared to 8.1. Instead if is triggerable via API in GridDropTarget. * Refactor sorted grid drop logic to server side * Block setDropMode calls Blocking setDropMode set values if the grid has been sorted and drop on sorted rows is not allowed. The value is used once the grid is not sorted anymore or the drops are allowed on sorted rows.
* Fix setting custom tab index for TabSheet or Accordion (#9574) (#10278)Ansku2017-11-102-7/+25
|
* Add ContentMode for row and cell descriptions in Grid (#10282)Teemu Suo-Anttila2017-11-102-29/+170
|
* Make focus circulate in modal dialog to improve accessibility (#10260)Péter Török2017-11-073-3/+15
| | | Make focus circulate in modal dialog to improve accessibility
* Use Logger instead of VConsole (#10249)Ahmed Ashour2017-11-061-2/+7
| | | Because VConsole is deprecated and it recommends using Logger instead
* Use lambda expressions. (#10268)Ahmed Ashour2017-11-01493-9946/+4276
|
* Use local variable for getWidget(). (#10253)Ahmed Ashour2017-10-311-6/+7
| | | | | In some places, getWidget() is called many times, and I believe this can have a litte performance improvement, since in some cases super.getWidget() is called more than once.
* Fix end of line comments, which were made by automatic formatter (#10234)Ahmed Ashour2017-10-3117-46/+54
|
* Remove redundant interface already implemented by super class. (#10258)Ahmed Ashour2017-10-319-21/+9
|
* Fix combo box suggestion popup height (#10256)Adam Wagner2017-10-304-0/+80
| | | Fixes #10214
* add Grid.Column#get/setAssistiveCaption (#10219)Knoobie2017-10-302-0/+89
| | | | | | | | | | | | | | | | | | | | | | | | * add Grid#Column#get/setAssistiveCaption * fix test and update doc * move testGridAssistiveCaption to GridTest * delete test file * delete test file * Delete GridAssistiveCaptionTest.java * Create GridAssistiveCaptionTest * Create GridAssistiveCaption * Rename GridAssistiveCaption to GridAssistiveCaption.java * Rename GridAssistiveCaptionTest to GridAssistiveCaptionTest.java * Reformat using eclipse
* Use lambda with Handlers (#10229)Ahmed Ashour2017-10-2730-388/+183
| | | Also improve naming by replacing one-letter variable names.
* Use lambda with Listeners (#10222)Ahmed Ashour2017-10-26162-1863/+831
| | | Also use "event" as the name for events
* Remove trailing spaces (#10224)Ahmed Ashour2017-10-269-19/+19
|
* Grid column to be sortable when implemented/supported (Fixes #8792). (#10190)Ahmed Ashour2017-10-238-32/+303
| | | | | | | | | | | * Grid column to be sortable when implemented/supported * Fix GridDeclarativeTest * Parameterize to Grid<Person> * Revert Parameterize to Grid<Person>, JDK with generics. * Assertions for other columns * Fix test Fixes #8792
* Fix typos (#10213)Ahmed Ashour2017-10-202-2/+2
| | | | | | * Fix typos * Fix
* Check class name type on Grid cell mouse over (#10194)Adam Wagner2017-10-202-0/+64
| | | | | | | | | | * Check whether className is of type string * Move string type checker method to widget util * Fix formatting of WidgetUtil * Break svg into lines
* Improve role usage in grid (#10206)Knoobie2017-10-201-1/+9
| | | | | | | | | | | | | | | | | | | | | | | | * add role="row" and role="gridcell" * optimize code and add additional rows for the header * add simple test * improve code and add rowgroup * add debug log * add more log to test * remove debug test info and add role before appending to tr * wording - change contains to contain * create enum for magic strings, change comments and method signature * rename enum to be singular and rename param roleName to role * update javadoc, rename and make enum public
* Use .toLowerCase and .toUpperCase(Locale.ROOT) (#10182)Ahmed Ashour2017-10-2039-162/+223
| | | | | | | | * Use .toLowerCase and .toUpperCase(Locale.ROOT) * Spaces * add spaces after if(
* Scheduler.ScheduledCommand and RepeatingCommand to be lambda (#10203)Ahmed Ashour2017-10-201-287/+130
| | | | | | | | * Scheduler.ScheduledCommand and RepeatingCommand to be lambda * Restore <table> in javadoc * Fix docs
* Add spaces after 'if' and 'for' in JavaScript (#10199)Ahmed Ashour2017-10-205-7/+7
| | | | | | | | * Add spaces after 'if' and 'for' in JavaScript * Revert to old format * Remove whitespaces
* Simplify lambda expressions (#10198)Ahmed Ashour2017-10-2039-313/+248
| | | | | | | | * Simplify lambda expressions And remove unneeded 'return' keyword. * Format
* AbstractDateField: set value after being invalid (#10187)Ahmed Ashour2017-10-203-9/+114
| | | | Fixes #9763 Fixes #9978
* Fix AbstractDateField to correctly show week day names (#10188)Ahmed Ashour2017-10-163-2/+106
| | | Fixes #9200
* Simplify waitUntil() in tests (#10181)Ahmed Ashour2017-10-1323-200/+58
|
* Use Collection.isEmpty() (#10172)Ahmed Ashour2017-10-1212-24/+25
|
* Add ErrorLevel to Validators and results (#10099)Teemu Suo-Anttila2017-10-112-0/+70
| | | Fixes #9792
* Add aria-rowcount to grid (#10167)Knoobie2017-10-115-1/+255
| | | This is based on discussion from vaadin/vaadin-grid#1023 .
* Prevent Grid refreshAll from getting stuck due mismatched state (#10161)Ansku2017-10-101-0/+93
| | | Fixes #10038
* Fix typos (#10158)Ahmed Ashour2017-10-103-6/+9
|
* Remove unneeded .toString() (#10141)Ahmed Ashour2017-10-1042-107/+86
|
* Edit grid row by index - server side (#10040)Piotr Wilkin2017-10-102-2/+32
| | | | | Opening grid editor from server side. Fixes #8477. Addressing #8820 will be the user's responsibility as fetching index of item might be slow.
* Use StringBuilder instead of StringBuffer (#10154)Ahmed Ashour2017-10-097-9/+9
|
* Fix typos (#10124)Ahmed Ashour2017-10-0419-63/+67
|
* Add role="grid" and aria-multiselectable to grid (#10009)Knoobie2017-10-042-0/+100
| | | Also adds aria-selected for grid rows.
* Use static import of Assert in tests (#10126)Ahmed Ashour2017-10-03431-2376/+2743
| | | | Also removes dependency on junit.framework.TestCase .
* Remove unneeded .toArray() (#10131)Ahmed Ashour2017-10-031-1/+1
| | | Use for each loop.
* Use enhanced for loop for arrays. (#10121)Ahmed Ashour2017-10-0215-66/+58
|
* Simplify conditional logic. (#10122)Ahmed Ashour2017-10-022-2/+0
| | | And remove unused imports.
* Use enhanced for loop instead of Iterator. (#10100)Ahmed Ashour2017-09-295-40/+14
|
* Use StandardCharsets.UTF_8 (#10113)Ahmed Ashour2017-09-294-12/+12
|
* Remove auto-generated comment (#10111)Ahmed Ashour2017-09-2926-114/+23
|
* Handle 'z' (timezone) in AbstractDateField.setDateFormat() (#8844)Ahmed Ashour2017-09-282-0/+282
|
* Use interface instead of implementation (#10073)Ahmed Ashour2017-09-2831-52/+69
|
* Use single character for StringBuilder.append (#10102)Ahmed Ashour2017-09-286-16/+16
|
* Update browser version test for Chrome 61 (#10098)Henri Sara2017-09-271-1/+1
|
* Fix typos (#10095)Ahmed Ashour2017-09-277-7/+7
|
* Support addCloseListener for Notification (#10027)Ahmed Ashour2017-09-272-0/+96
| | | | | Converts Notification to an Extension and adds support for listening to the closing of notifications. Fixes #888
* Add option to use PushState instead of URI fragments in Navigator (#10042)Teemu Suo-Anttila2017-09-275-0/+33
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Navigator now by default uses pushState and normal URLs * added documentation for pushState and updated Navigator documentation * improving docs etc, adding one TODO to be solved before merging * pushState/replaceState no work better with changing titles * Making uri fragment navigator work when not using specially mapped UI * Revert to older default, add annotation for selecting * Fix tests, add null checks * Reorder if-clause, fix tests * Revert unnecessary test change * Use correct variable in UI, fix test clean up * Updates to JavaDocs, fix some methods and tests * Add comments, fix test ui, TODO for fallbacks * Navigation documentation, JavaDocs, removed TODOs * Documentation fixes * Improve JavaDocs * Fix link name in documentation * Improve throws declaration in getLocation * Change documentation about the PushState based navigation * Add since tags * Add since tags for UI
* Implement error level on client side (#9817)Adam Wagner2017-09-274-3/+373
| | | | | | | Add additional class names and style to components and error indicators to distinguish different error levels. Vaadin 8 implementation of #9816. Cherry picked changes and added compatibility package component changes and tests. Resolves #3139