aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2013-06-20 15:32:54 +0100
committerVsevolod Stakhov <vsevolod@highsecure.ru>2013-06-20 15:32:54 +0100
commit62238026d4230392c8383db90b969cbdc8d4166c (patch)
tree4f95a7f711dc0c201fbe80347e86294eae5c6d7d /CMakeLists.txt
parenta2b3adbcd3dcd61f7117d98bad3b0b270fb96c7a (diff)
downloadrspamd-62238026d4230392c8383db90b969cbdc8d4166c.tar.gz
rspamd-62238026d4230392c8383db90b969cbdc8d4166c.zip
Forgotten in the previous commit.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fa83ad866..a06264774 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -328,6 +328,8 @@ IF(CMAKE_SYSTEM_NAME STREQUAL "SunOS")
LIST(APPEND CMAKE_REQUIRED_LIBRARIES nsl)
LIST(APPEND CMAKE_REQUIRED_LIBRARIES socket)
LIST(APPEND CMAKE_REQUIRED_LIBRARIES umem)
+ # Ugly hack, but FindOpenSSL on Solaris does not link with libcrypto
+ LIST(APPEND CMAKE_REQUIRED_LIBRARIES crypto)
SET(CMAKE_VERBOSE_MAKEFILE ON)
SET(CMAKE_INSTALL_RPATH_USE_LINK_PATH FALSE)
SET(CMAKE_INSTALL_RPATH "${PREFIX}/lib")