aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2015-10-08 16:56:50 +0100
committerVsevolod Stakhov <vsevolod@highsecure.ru>2015-10-08 16:56:50 +0100
commit694ef3873dece023fe1550d34e36a10b3167415c (patch)
treeab8f81828345e6992eb4243983b62563488e1df0 /CMakeLists.txt
parentdb7dba5ba7daec61ca505e0299bfbf46d7f22167 (diff)
downloadrspamd-694ef3873dece023fe1550d34e36a10b3167415c.tar.gz
rspamd-694ef3873dece023fe1550d34e36a10b3167415c.zip
Check for SOCK_SEQPACKET definition.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 72b3e05de..cfaa632da 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -818,6 +818,7 @@ CHECK_SYMBOL_EXISTS(getaddrinfo "sys/types.h;sys/socket.h;netdb.h" HAVE_GETADDRI
CHECK_SYMBOL_EXISTS(sched_yield "sched.h" HAVE_SCHED_YIELD)
CHECK_SYMBOL_EXISTS(__get_cpuid "cpuid.h" HAVE_GET_CPUID)
CHECK_SYMBOL_EXISTS(PCRE_CONFIG_JIT "pcre.h" HAVE_PCRE_JIT)
+CHECK_SYMBOL_EXISTS(SOCK_SEQPACKET "sys/types.h;sys/socket.h" HAVE_SOCK_SEQPACKET)
# Some PCRE implementations are lacking of pcre_jit_exec fast path
SET(_PCRE_FAST_TEST "