aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@rspamd.com>2023-03-06 08:40:16 +0000
committerVsevolod Stakhov <vsevolod@rspamd.com>2023-03-06 08:40:16 +0000
commitb4f58d222f627778333ad9b6e45cbc0ee6fcd590 (patch)
treea3f2140f37a3f7892ff48878c170aa4ec13437b9 /debian
parent65ba2f310d6475d0a829e6c036acba6f68496b3b (diff)
downloadrspamd-b4f58d222f627778333ad9b6e45cbc0ee6fcd590.tar.gz
rspamd-b4f58d222f627778333ad9b6e45cbc0ee6fcd590.zip
[Minor] Use luajit all the time in Debian builds
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules8
1 files changed, 1 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index 72823c3fc..dc2837d4e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,11 +10,7 @@ FLAVORS = release asan
CONFIG_asan = -DCMAKE_BUILD_TYPE=Debug -DSANITIZE=address -DENABLE_LTO=OFF
CONFIG_release = -DCMAKE_BUILD_TYPE=RelWithDebInfo -DENABLE_LTO=ON
-ifneq ($(filter $(DEB_HOST_ARCH),amd64 armel armhf i386 mips mips64el mipsel ppc64 ppc64el),)
- ENABLE_LUAJIT := -DENABLE_LUAJIT=ON -DLUA_ROOT=/luajit-build
-else
- ENABLE_LUAJIT := -DENABLE_LUAJIT=OFF
-endif
+ENABLE_LUAJIT := -DENABLE_LUAJIT=ON -DLUA_ROOT=/luajit-build
# Can be filled by a build system
EXTRA_ARGS :=
@@ -50,10 +46,8 @@ configure_%:
-DCMAKE_BUILD_WITH_INSTALL_RPATH=ON \
-DDEBIAN_BUILD=1 \
-DENABLE_PCRE2=ON \
- -DENABLE_LUAJIT=$(ENABLE_LUAJIT) \
-DENABLE_LIBUNWIND=ON \
-DWANT_SYSTEMD_UNITS=ON \
- -DENABLE_STATIC_LIBCXX=OFF \
-DENABLE_LIBCXX=AUTO \
$(ENABLE_HYPERSCAN) \
$(ENABLE_LUAJIT) \