aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/lua-torch/torch7/lib/luaT/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/lua-torch/torch7/lib/luaT/CMakeLists.txt')
-rw-r--r--contrib/lua-torch/torch7/lib/luaT/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/contrib/lua-torch/torch7/lib/luaT/CMakeLists.txt b/contrib/lua-torch/torch7/lib/luaT/CMakeLists.txt
new file mode 100644
index 000000000..ebe788cef
--- /dev/null
+++ b/contrib/lua-torch/torch7/lib/luaT/CMakeLists.txt
@@ -0,0 +1,15 @@
+# avoid some cmake warnings
+IF(POLICY CMP0026)
+ CMAKE_POLICY(SET CMP0026 OLD)
+ENDIF()
+
+INCLUDE_DIRECTORIES(${LUA_INCDIR})
+IF(LUALIB)
+ LINK_DIRECTORIES(${LUA_LIBDIR}) # note: must be done before defining target
+ENDIF()
+
+ADD_LIBRARY(luaT STATIC luaT.h luaT.c)
+
+IF(LUALIB)
+ TARGET_LINK_LIBRARIES(luaT ${LUALIB}) # must be done after ;)
+ENDIF()