aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2024-01-24 10:27:50 +0100
committerPierre Ossman <ossman@cendio.se>2024-01-24 10:27:50 +0100
commit0bec9f984a5369f0bf6af07649fe164c998890c8 (patch)
tree0ae066848efad68daed393e90522401d562c7594 /CMakeLists.txt
parent986280b382d57ef4f68d2d4afb13b26772e5acb0 (diff)
parentbaa21c364f842e609a4782dc594725e524cd409e (diff)
downloadtigervnc-0bec9f984a5369f0bf6af07649fe164c998890c8.tar.gz
tigervnc-0bec9f984a5369f0bf6af07649fe164c998890c8.zip
Merge branch 'systemd' of https://github.com/CendioOssman/tigervnc
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e8d8d85d..f1bfd618 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -301,6 +301,14 @@ if(UNIX AND NOT APPLE)
endif()
endif()
+# check for systemd support (socket activation)
+if(UNIX AND NOT APPLE)
+ find_package(PkgConfig)
+ if (PKG_CONFIG_FOUND)
+ pkg_check_modules(LIBSYSTEMD libsystemd)
+ endif()
+endif()
+
# Generate config.h and make sure the source finds it
configure_file(config.h.in config.h)
add_definitions(-DHAVE_CONFIG_H)