aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2022-05-30 10:53:32 +0200
committerPierre Ossman <ossman@cendio.se>2022-06-07 10:06:32 +0200
commit101cef956de048160ddd80f1aaa6e80df0f530fa (patch)
tree141f3b9b046fc7ba90c72da3f30fd06ea82a770c /CMakeLists.txt
parent4cf31302a1dd887e72481ed4355a9f435d91eb6c (diff)
downloadtigervnc-101cef956de048160ddd80f1aaa6e80df0f530fa.tar.gz
tigervnc-101cef956de048160ddd80f1aaa6e80df0f530fa.zip
Find FFMPEG using pkg-config
This is the standard method of finding it on Unix systems, so make sure we use it. Still keep a fallback, though, for other systems, e.g. Windows.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 4 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e5807def..d88b177f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -179,18 +179,11 @@ if(ENABLE_H264)
set(H264_LIBS "WIN") # may be LIBAV in the future
set(H264_LIBRARIES ole32 mfplat mfuuid wmcodecdspuuid)
else()
- check_include_files(libavcodec/avcodec.h HAVE_AVCODEC_H)
- check_include_files(libavutil/avutil.h HAVE_AVUTIL_H)
- check_include_files(libswscale/swscale.h HAVE_SWSCALE_H)
- if (HAVE_AVCODEC_H AND HAVE_AVUTIL_H AND HAVE_SWSCALE_H)
- find_path(AVCODEC_INCLUDE_DIR libavcodec/avcodec.h)
- find_library(AVCODEC_LIBRARY avcodec)
- find_path(AVUTIL_INCLUDE_DIR libavutil/avutil.h)
- find_library(AVUTIL_LIBRARY avutil)
- find_path(SWSCALE_INCLUDE_DIR libswscale/swscale.h)
- find_library(SWSCALE_LIBRARY swscale)
+ find_package(Ffmpeg)
+ if (AVCODEC_FOUND AND AVUTIL_FOUND AND SWSCALE_FOUND)
set(H264_INCLUDE_DIRS ${AVCODEC_INCLUDE_DIRS} ${AVUTIL_INCLUDE_DIRS} ${SWSCALE_INCLUDE_DIRS})
- set(H264_LIBRARIES ${AVCODEC_LIBRARY} ${AVUTIL_LIBRARY} ${SWSCALE_LIBRARY})
+ set(H264_LIBRARIES ${AVCODEC_LIBRARIES} ${AVUTIL_LIBRARIES} ${SWSCALE_LIBRARIES})
+ set(H264_LIBRARY_DIRS ${AVCODEC_LIBRARY_DIRS} ${AVUTIL_LIBRARY_DIRS} ${SWSCALE_LIBRARY_DIRS})
add_definitions("-D__STDC_CONSTANT_MACROS")
add_definitions("-DHAVE_H264")
set(H264_LIBS "LIBAV")