aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdam Tkac <atkac@redhat.com>2011-01-19 14:20:34 +0000
committerAdam Tkac <atkac@redhat.com>2011-01-19 14:20:34 +0000
commit125bd259b9eda1270f2fb85b0caded5b8780fe37 (patch)
tree582c530527dd6d6fdf86abdf6d35e812fc4f021f /CMakeLists.txt
parent179d2b14ecf33058c1bc733cfef5854744809fcc (diff)
downloadtigervnc-125bd259b9eda1270f2fb85b0caded5b8780fe37.tar.gz
tigervnc-125bd259b9eda1270f2fb85b0caded5b8780fe37.zip
[Development] Add possibility to build Windows programs with GNUTLS via cmake.
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4241 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9c08e8b0..9d5bff7a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -85,6 +85,14 @@ if(MINGW)
"<CMAKE_RC_COMPILER> <FLAGS> <DEFINES> -o <OBJECT> --output-format=coff <SOURCE>")
endif()
+# Check for GNUTLS library
+find_package(GnuTLS)
+if(GNUTLS_FOUND)
+ include_directories(${GNUTLS_INCLUDE_DIR})
+ add_definitions("-DHAVE_GNUTLS")
+ add_definitions(${GNUTLS_DEFINITIONS})
+endif()
+
# Generate config.h
include(CheckIncludeFiles)
include(CheckFunctionExists)