aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2024-08-15 14:14:59 +0200
committerPierre Ossman <ossman@cendio.se>2024-08-15 14:14:59 +0200
commit3aca8be33ca26048bce18c59bcfebe03a6a52b12 (patch)
treea0467783df9b40cc0f7780911878df40edcf1ec5 /CMakeLists.txt
parent242488d180526e75d4256a82e83c95d27373b464 (diff)
parent73e6e18b08f341d1fbda39431ff59c8884f3081b (diff)
downloadtigervnc-3aca8be33ca26048bce18c59bcfebe03a6a52b12.tar.gz
tigervnc-3aca8be33ca26048bce18c59bcfebe03a6a52b12.zip
Merge branch 'master' of https://github.com/prownd/tigervnc
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 07a859ca..b57b5e61 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -336,6 +336,20 @@ if(UNIX AND NOT APPLE)
endif()
endif()
+# check for password pwquality check support
+option(ENABLE_PWQUALITY "Enable password pwquality check" ON)
+if(ENABLE_PWQUALITY)
+ if(UNIX)
+ find_package(PkgConfig)
+ if(PKG_CONFIG_FOUND)
+ pkg_check_modules(PWQUALITY pwquality)
+ if(PWQUALITY_FOUND)
+ add_definitions(-DHAVE_PWQUALITY)
+ endif()
+ endif()
+ endif()
+endif()
+
# Generate config.h and make sure the source finds it
configure_file(config.h.in config.h)
add_definitions(-DHAVE_CONFIG_H)