aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2011-03-08 13:06:46 +0000
committerPierre Ossman <ossman@cendio.se>2011-03-08 13:06:46 +0000
commit7f44326f4ad81ec1be365210a7cd4232c751cb56 (patch)
tree4e13eaa68deee6d77270d68992054f1ca79d7c4e /CMakeLists.txt
parent0153e23facf7c694bfaf17d60b092982e37ef633 (diff)
downloadtigervnc-7f44326f4ad81ec1be365210a7cd4232c751cb56.tar.gz
tigervnc-7f44326f4ad81ec1be365210a7cd4232c751cb56.zip
Consolidate CMake modules includes at the top of the file.
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4328 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 40017c55..efcd49d2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,6 +4,11 @@
cmake_minimum_required(VERSION 2.6)
+include(CheckIncludeFiles)
+include(CheckFunctionExists)
+include(CheckTypeSize)
+include(CheckCSourceCompiles)
+
project(TigerVNC)
set(VERSION 1.0.90)
@@ -99,7 +104,6 @@ endif()
find_package(JPEG REQUIRED)
# Warn if it doesn't seem to be the accelerated libjpeg that's found
-include(CheckCSourceCompiles)
check_c_source_compiles("#include <stdio.h>\n#include <jpeglib.h>\nint main(int c, char** v) { return JCS_EXT_RGBX; }" FOUND_JPEG_TURBO)
if(NOT FOUND_JPEG_TURBO)
message(STATUS "WARNING: You are not using libjpeg-turbo. Performance will suffer.")
@@ -114,9 +118,6 @@ if(GNUTLS_FOUND)
endif()
# Generate config.h
-include(CheckIncludeFiles)
-include(CheckFunctionExists)
-include(CheckTypeSize)
if(WIN32)
set(CMAKE_EXTRA_INCLUDE_FILES winsock2.h ws2tcpip.h)
set(CMAKE_REQUIRED_LIBRARIES ws2_32)