aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2021-11-05 12:53:11 +0100
committerPierre Ossman <ossman@cendio.se>2021-11-05 13:36:37 +0100
commitcb3c78f43394930f890bfb6fb34834d8d1a58496 (patch)
tree4163f747f92bcc560f24ef0cbcf568c9389c625a /CMakeLists.txt
parent011f7deac219989bee5be9fdb7756016d5896973 (diff)
downloadtigervnc-cb3c78f43394930f890bfb6fb34834d8d1a58496.tar.gz
tigervnc-cb3c78f43394930f890bfb6fb34834d8d1a58496.zip
Raise CMake requirement to 3.10
It's difficult to support both old and new versions, so raise the requirement to the oldest that is commonly used, which is CMake 3.10.2 on Ubuntu 18.04.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 1 insertions, 21 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3f54fbfe..50247c7d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,13 +2,7 @@
# Setup
#
-cmake_minimum_required(VERSION 2.8.11)
-if(POLICY CMP0022)
- cmake_policy(SET CMP0022 OLD)
-endif()
-if(${CMAKE_VERSION} VERSION_LESS "3.4.0")
- message(WARNING "CMake 3.4.0 or newer is required to get correct default installation paths")
-endif()
+cmake_minimum_required(VERSION 3.10.0)
# Internal cmake modules
set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/Modules)
@@ -117,20 +111,6 @@ else()
message(STATUS "32-bit build")
endif()
-# Versions of CMake before 2.8.7 do not properly support resource compilation
-# with MinGW. Boo!
-if(MINGW AND "${CMAKE_VERSION}" VERSION_LESS "2.8.7")
- if(NOT DEFINED RC)
- set(CMAKE_RC_COMPILER_INIT windres)
- else()
- set(CMAKE_RC_COMPILER_INIT ${RC})
- endif()
- enable_language(RC)
- message(STATUS "Resource compiler: ${CMAKE_RC_COMPILER}")
- set(CMAKE_RC_COMPILE_OBJECT
- "<CMAKE_RC_COMPILER> <FLAGS> <DEFINES> -o <OBJECT> --output-format=coff <SOURCE>")
-endif()
-
# MinGW64 has header support but no library support for IActiveDesktop, so we
# need to check for both the header and library and use our own implementation
# in common/os if either doesn't exist.