aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2023-01-30 20:23:18 +0100
committerPierre Ossman <ossman@cendio.se>2023-01-30 20:24:32 +0100
commitcb4f920199e4d6239e9c8e59ae5276f709b0ebc4 (patch)
tree1ba3727003f18132654668e8d5c413feb59fefff /CMakeLists.txt
parentbf0fb9129d397f7bbb27ba784890cd9c2102d839 (diff)
downloadtigervnc-cb4f920199e4d6239e9c8e59ae5276f709b0ebc4.tar.gz
tigervnc-cb4f920199e4d6239e9c8e59ae5276f709b0ebc4.zip
Remove old mingw CMake checks
This should have been removed with the code using these defines in 03ca975.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 0 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 48e49924..e8d8d85d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -112,14 +112,6 @@ if(APPLE)
add_definitions(-D__ASSERT_MACROS_DEFINE_VERSIONS_WITHOUT_UNDERSCORES=0)
endif()
-# MinGW64 has header support but no library support for IActiveDesktop, so we
-# need to check for both the header and library and use our own implementation
-# in common/os if either doesn't exist.
-if(WIN32)
- check_c_source_compiles("#include <windows.h>\n#include <wininet.h>\n#include <shlobj.h>\nint main(int c, char** v) {IActiveDesktop iad; (void)iad; return 0;}" HAVE_ACTIVE_DESKTOP_H)
- check_c_source_compiles("#include <windows.h>\n#include <wininet.h>\n#include <shlobj.h>\nint main(int c, char** v) {GUID i = CLSID_ActiveDesktop; (void)i; return 0;}" HAVE_ACTIVE_DESKTOP_L)
-endif()
-
# X11 stuff. It's in a if() so that we can say REQUIRED
if(UNIX AND NOT APPLE)
find_package(X11 REQUIRED)