aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2017-12-22 10:35:29 +0100
committerPierre Ossman <ossman@cendio.se>2020-03-12 10:51:24 +0100
commitdf25ae41194eb85a48ccfabd7cb7d2c338ff4300 (patch)
tree253d0e068786bdb7d46df0213a3c9404c08c3a98 /CMakeLists.txt
parentebaa948e4685adce59e84242458fafb6f900bf0a (diff)
downloadtigervnc-df25ae41194eb85a48ccfabd7cb7d2c338ff4300.tar.gz
tigervnc-df25ae41194eb85a48ccfabd7cb7d2c338ff4300.zip
Always install systemd services
It is the most common init system these days so it should not be hidden in the contrib/ directory. This also removes all old SysV files from the contrib packages.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e715f26c..f6742e7b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -33,12 +33,15 @@ set(DATA_DIR "${CMAKE_INSTALL_PREFIX}/share")
set(MAN_DIR "${DATA_DIR}/man")
set(LOCALE_DIR "${DATA_DIR}/locale")
set(DOC_DIR "${CMAKE_INSTALL_PREFIX}/share/doc/${CMAKE_PROJECT_NAME}-${VERSION}")
+set(UNIT_DIR "${CMAKE_INSTALL_PREFIX}/lib/systemd/system")
if(WIN32)
set(BIN_DIR "${CMAKE_INSTALL_PREFIX}")
set(DOC_DIR "${CMAKE_INSTALL_PREFIX}")
endif()
+option(INSTALL_SYSTEMD_UNITS "Install TigerVNC systemd units" ON)
+
if(MSVC)
message(FATAL_ERROR "TigerVNC cannot be built with Visual Studio. Please use MinGW")
endif()