aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2012-03-27 10:29:50 +0000
committerPierre Ossman <ossman@cendio.se>2012-03-27 10:29:50 +0000
commite43d1aaea61f51da5eda8c571301330dd7ed6286 (patch)
treed8da7caec3da50c52e839cac3d6c7ff27ddf381a /CMakeLists.txt
parent448fd3a5e720537f82138874ff1deff38dd2e5fe (diff)
downloadtigervnc-e43d1aaea61f51da5eda8c571301330dd7ed6286.tar.gz
tigervnc-e43d1aaea61f51da5eda8c571301330dd7ed6286.zip
Using libXft means using libfontconfig, so make sure we add that to
the link line. git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4875 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dd03a5a2..9bb3f529 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -257,7 +257,10 @@ find_package(FLTK)
if(UNIX AND NOT APPLE)
# No proper handling for extra X11 libs that FLTK might need...
if(X11_Xft_FOUND)
- set(FLTK_LIBRARIES ${FLTK_LIBRARIES} ${X11_Xft_LIB})
+ # Xft headers include references to fontconfig, so we need
+ # to link to that as well
+ find_library(FONTCONFIG_LIB fontconfig)
+ set(FLTK_LIBRARIES ${FLTK_LIBRARIES} ${X11_Xft_LIB} ${FONTCONFIG_LIB})
endif()
if(X11_Xinerama_FOUND)
set(FLTK_LIBRARIES ${FLTK_LIBRARIES} ${X11_Xinerama_LIB})