aboutsummaryrefslogtreecommitdiffstats
path: root/common/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2016-09-22 16:23:32 +0200
committerPierre Ossman <ossman@cendio.se>2016-09-22 16:23:32 +0200
commit92c52c37023cac984baffd936bc6d759baa1688d (patch)
tree459fd09e33261f121d19ea3245378aeeec481baf /common/CMakeLists.txt
parentd959e7ac7471ae74fd9d2a60ed3f4fcd24ca624d (diff)
downloadtigervnc-92c52c37023cac984baffd936bc6d759baa1688d.tar.gz
tigervnc-92c52c37023cac984baffd936bc6d759baa1688d.zip
Apply -fPIC on all compilers
Diffstat (limited to 'common/CMakeLists.txt')
-rw-r--r--common/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/common/CMakeLists.txt b/common/CMakeLists.txt
index e0431e62..e4489f6f 100644
--- a/common/CMakeLists.txt
+++ b/common/CMakeLists.txt
@@ -9,7 +9,7 @@ add_subdirectory(rfb)
# because PIC code does not exist on that platform and MinGW complains if -fPIC
# is passed (additionally, libvnc is not used on Windows.)
-if(CMAKE_COMPILER_IS_GNUCXX AND NOT WIN32)
+if(NOT WIN32)
set_target_properties(os rdr network Xregion rfb
PROPERTIES COMPILE_FLAGS -fPIC)
endif()