aboutsummaryrefslogtreecommitdiffstats
path: root/common/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2015-02-03 09:54:49 +0100
committerPierre Ossman <ossman@cendio.se>2015-02-03 09:54:49 +0100
commitcc8c6a296f48552dde4375c5b491225262b4814f (patch)
tree3aa592a2b67137cd60664cda546404f15daa12a1 /common/CMakeLists.txt
parent27eb55e1975c4f558f6a53d573091e76064cc8e7 (diff)
downloadtigervnc-cc8c6a296f48552dde4375c5b491225262b4814f.tar.gz
tigervnc-cc8c6a296f48552dde4375c5b491225262b4814f.zip
Drop bundled zlib
We're not doing a sufficient job of keeping this updated so list it as an external requirement instead.
Diffstat (limited to 'common/CMakeLists.txt')
-rw-r--r--common/CMakeLists.txt10
1 files changed, 0 insertions, 10 deletions
diff --git a/common/CMakeLists.txt b/common/CMakeLists.txt
index a645aa58..16e2a35e 100644
--- a/common/CMakeLists.txt
+++ b/common/CMakeLists.txt
@@ -1,10 +1,3 @@
-if(USE_INCLUDED_ZLIB)
- add_subdirectory(zlib)
-
- set(ZLIB_INCLUDE_DIRS ${CMAKE_SOURCE_DIR}/common/zlib)
- set(ZLIB_LIBRARIES zlib)
-endif()
-
add_subdirectory(os)
add_subdirectory(rdr)
add_subdirectory(network)
@@ -19,7 +12,4 @@ add_subdirectory(rfb)
if(CMAKE_COMPILER_IS_GNUCXX AND (CMAKE_SIZEOF_VOID_P MATCHES 8) AND NOT WIN32)
set_target_properties(os rdr network Xregion rfb
PROPERTIES COMPILE_FLAGS -fPIC)
- if(USE_INCLUDED_ZLIB)
- set_target_properties(zlib PROPERTIES COMPILE_FLAGS -fPIC)
- endif()
endif()