aboutsummaryrefslogtreecommitdiffstats
path: root/common/CMakeLists.txt
diff options
context:
space:
mode:
authorDRC <dcommander@users.sourceforge.net>2011-08-23 20:35:06 +0000
committerDRC <dcommander@users.sourceforge.net>2011-08-23 20:35:06 +0000
commitce82f4bbcd4fe491132a0b9aa772e25159179ba1 (patch)
treec3123c8d85cc70653faa936931ddea998e7e6b08 /common/CMakeLists.txt
parentf340e7c33813e4979e817209fe3d93d3a685cfdf (diff)
downloadtigervnc-ce82f4bbcd4fe491132a0b9aa772e25159179ba1.tar.gz
tigervnc-ce82f4bbcd4fe491132a0b9aa772e25159179ba1.zip
Move setting of PIC code to a central location
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4648 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'common/CMakeLists.txt')
-rw-r--r--common/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/common/CMakeLists.txt b/common/CMakeLists.txt
index 1d9f1d66..fd22455a 100644
--- a/common/CMakeLists.txt
+++ b/common/CMakeLists.txt
@@ -14,3 +14,16 @@ add_subdirectory(rdr)
add_subdirectory(network)
add_subdirectory(Xregion)
add_subdirectory(rfb)
+
+# For any convenience libraries that are linked into libvnc.so, we need to
+# explicitly build their corresponding sources using PIC. WIN32 is excluded
+# because PIC code does not exist on that platform and MinGW complains if -fPIC
+# is passed (additionally, libvnc is not used on Windows.)
+
+if(CMAKE_COMPILER_IS_GNUCXX AND (CMAKE_SIZEOF_VOID_P MATCHES 8) AND NOT WIN32)
+ set_target_properties(os rdr network Xregion rfb
+ PROPERTIES COMPILE_FLAGS -fPIC)
+ if(USE_INCLUDED_ZLIB)
+ set_target_properties(zlib PROPERTIES COMPILE_FLAGS -fPIC)
+ endif()
+endif()