aboutsummaryrefslogtreecommitdiffstats
path: root/common/os/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2023-03-24 19:34:27 +0100
committerPierre Ossman <ossman@cendio.se>2023-03-31 10:37:35 +0200
commit00dc3c0c8d14d2d281e9e273f78abe6d44ed537e (patch)
tree3e468c0b21107d23d4f4a60b52cb6b5f0eb8d151 /common/os/CMakeLists.txt
parentb96e9c1fe6f45bbf06b615dab657ec66ac856f07 (diff)
downloadtigervnc-00dc3c0c8d14d2d281e9e273f78abe6d44ed537e.tar.gz
tigervnc-00dc3c0c8d14d2d281e9e273f78abe6d44ed537e.zip
Add all common inter-dependencies
This is important in case there are build flags that need to propagate between libraries for things to build correctly.
Diffstat (limited to 'common/os/CMakeLists.txt')
-rw-r--r--common/os/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/common/os/CMakeLists.txt b/common/os/CMakeLists.txt
index e93c74b5..deaf2f96 100644
--- a/common/os/CMakeLists.txt
+++ b/common/os/CMakeLists.txt
@@ -5,6 +5,8 @@ add_library(os STATIC
Thread.cxx
os.cxx)
+target_link_libraries(os rdr)
+
if(UNIX)
target_link_libraries(os pthread)
endif()