aboutsummaryrefslogtreecommitdiffstats
path: root/common/os/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2015-11-12 12:21:58 +0100
committerPierre Ossman <ossman@cendio.se>2015-11-27 11:07:43 +0100
commit504afa27c1128de9287599e67cf01bd06df06908 (patch)
treed6ae146456270ece4f721b512e345249d3cdaf16 /common/os/CMakeLists.txt
parent3da238dee89906d952487fbe0d138dac1f5df3ea (diff)
downloadtigervnc-504afa27c1128de9287599e67cf01bd06df06908.tar.gz
tigervnc-504afa27c1128de9287599e67cf01bd06df06908.zip
Make the decoder multi-threaded
This implements the basic infrastructure for multi-threaded decoding of rects. However there is just one thread reading data and one thread decoding it. More logic is needed to safely decode multiple rects at the same time.
Diffstat (limited to 'common/os/CMakeLists.txt')
-rw-r--r--common/os/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/common/os/CMakeLists.txt b/common/os/CMakeLists.txt
index b5749594..7644341a 100644
--- a/common/os/CMakeLists.txt
+++ b/common/os/CMakeLists.txt
@@ -7,5 +7,9 @@ add_library(os STATIC
os.cxx)
if(UNIX)
+ target_link_libraries(os pthread)
+endif()
+
+if(UNIX)
libtool_create_control_file(os)
endif()