aboutsummaryrefslogtreecommitdiffstats
path: root/common/rdr/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2023-01-04 19:16:13 +0100
committerPierre Ossman <ossman@cendio.se>2023-01-04 19:17:28 +0100
commitca0955c3fe71478bede0950bd7b22f31f7e1fb34 (patch)
treeb7fafcdd00207e79a72728d058a149d7f07c67eb /common/rdr/CMakeLists.txt
parentff25168a531bf9e0dd0d3ba96ad9c2966c64e944 (diff)
downloadtigervnc-ca0955c3fe71478bede0950bd7b22f31f7e1fb34.tar.gz
tigervnc-ca0955c3fe71478bede0950bd7b22f31f7e1fb34.zip
Mark system include paths correctly
This makes sure the compiler doesn't complain about problems in those files.
Diffstat (limited to 'common/rdr/CMakeLists.txt')
-rw-r--r--common/rdr/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/common/rdr/CMakeLists.txt b/common/rdr/CMakeLists.txt
index 7f642b48..429d0c72 100644
--- a/common/rdr/CMakeLists.txt
+++ b/common/rdr/CMakeLists.txt
@@ -1,5 +1,5 @@
include_directories(${CMAKE_SOURCE_DIR}/common)
-include_directories(${ZLIB_INCLUDE_DIRS})
+include_directories(SYSTEM ${ZLIB_INCLUDE_DIRS})
add_library(rdr STATIC
AESInStream.cxx
@@ -22,11 +22,11 @@ add_library(rdr STATIC
target_link_libraries(rdr ${ZLIB_LIBRARIES} os)
if(GNUTLS_FOUND)
- include_directories(${GNUTLS_INCLUDE_DIR})
+ include_directories(SYSTEM ${GNUTLS_INCLUDE_DIR})
target_link_libraries(rdr ${GNUTLS_LIBRARIES})
endif()
if (NETTLE_FOUND)
- include_directories(${NETTLE_INCLUDE_DIRS})
+ include_directories(SYSTEM ${NETTLE_INCLUDE_DIRS})
target_link_libraries(rdr ${NETTLE_LIBRARIES})
target_link_directories(rdr PUBLIC ${NETTLE_LIBRARY_DIRS})
endif()