aboutsummaryrefslogtreecommitdiffstats
path: root/common/rfb/CMakeLists.txt
diff options
context:
space:
mode:
authorDRC <dcommander@users.sourceforge.net>2011-06-22 00:18:17 +0000
committerDRC <dcommander@users.sourceforge.net>2011-06-22 00:18:17 +0000
commit777290b4692c45f4854f9c917da18783c98010a0 (patch)
treef67bcccd123c9c62a5781dc2b8bd9ffbc71cceec /common/rfb/CMakeLists.txt
parent801ef7ca6c3f3a33cc7e9bafde0d50a265b533c1 (diff)
downloadtigervnc-777290b4692c45f4854f9c917da18783c98010a0.tar.gz
tigervnc-777290b4692c45f4854f9c917da18783c98010a0.zip
Detect and enable PAM authentication support
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4513 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'common/rfb/CMakeLists.txt')
-rw-r--r--common/rfb/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/common/rfb/CMakeLists.txt b/common/rfb/CMakeLists.txt
index 4ca93499..eddbaea4 100644
--- a/common/rfb/CMakeLists.txt
+++ b/common/rfb/CMakeLists.txt
@@ -72,6 +72,12 @@ endif(WIN32)
set(RFB_LIBRARIES ${JPEG_LIBRARIES} os)
+if(HAVE_PAM)
+ set(RFB_SOURCES ${RFB_SOURCES} UnixPasswordValidator.cxx
+ UnixPasswordValidator.h pam.c pam.h)
+ set(RFB_LIBRARIES ${RFB_LIBRARIES} ${PAM_LIBS})
+endif()
+
if(GNUTLS_FOUND)
set(RFB_SOURCES
${RFB_SOURCES}